summaryrefslogtreecommitdiffstats
path: root/src/backend/nls.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:44:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:44:03 +0000
commit293913568e6a7a86fd1479e1cff8e2ecb58d6568 (patch)
treefc3b469a3ec5ab71b36ea97cc7aaddb838423a0c /src/backend/nls.mk
parentInitial commit. (diff)
downloadpostgresql-16-293913568e6a7a86fd1479e1cff8e2ecb58d6568.tar.xz
postgresql-16-293913568e6a7a86fd1479e1cff8e2ecb58d6568.zip
Adding upstream version 16.2.upstream/16.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/backend/nls.mk')
-rw-r--r--src/backend/nls.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/backend/nls.mk b/src/backend/nls.mk
new file mode 100644
index 0000000..8263527
--- /dev/null
+++ b/src/backend/nls.mk
@@ -0,0 +1,32 @@
+# src/backend/nls.mk
+CATALOG_NAME = postgres
+GETTEXT_FILES = + gettext-files
+GETTEXT_TRIGGERS = $(BACKEND_COMMON_GETTEXT_TRIGGERS) \
+ GUC_check_errmsg \
+ GUC_check_errdetail \
+ GUC_check_errhint \
+ write_stderr \
+ yyerror \
+ jsonpath_yyerror:3 \
+ parser_yyerror \
+ replication_yyerror \
+ scanner_yyerror \
+ syncrep_yyerror \
+ report_invalid_record:2 \
+ ereport_startup_progress
+GETTEXT_FLAGS = $(BACKEND_COMMON_GETTEXT_FLAGS) \
+ GUC_check_errmsg:1:c-format \
+ GUC_check_errdetail:1:c-format \
+ GUC_check_errhint:1:c-format \
+ write_stderr:1:c-format \
+ report_invalid_record:2:c-format \
+ ereport_startup_progress:1:c-format
+
+gettext-files: distprep
+ find $(srcdir) $(srcdir)/../common $(srcdir)/../port -name '*.c' -print | LC_ALL=C sort >$@
+
+my-clean:
+ rm -f gettext-files
+
+.PHONY: my-clean
+clean: my-clean