summaryrefslogtreecommitdiffstats
path: root/src/tools/pg_bsd_indent/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:44:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:44:03 +0000
commit293913568e6a7a86fd1479e1cff8e2ecb58d6568 (patch)
treefc3b469a3ec5ab71b36ea97cc7aaddb838423a0c /src/tools/pg_bsd_indent/Makefile
parentInitial commit. (diff)
downloadpostgresql-16-293913568e6a7a86fd1479e1cff8e2ecb58d6568.tar.xz
postgresql-16-293913568e6a7a86fd1479e1cff8e2ecb58d6568.zip
Adding upstream version 16.2.upstream/16.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/tools/pg_bsd_indent/Makefile')
-rw-r--r--src/tools/pg_bsd_indent/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/src/tools/pg_bsd_indent/Makefile b/src/tools/pg_bsd_indent/Makefile
new file mode 100644
index 0000000..d176ceb
--- /dev/null
+++ b/src/tools/pg_bsd_indent/Makefile
@@ -0,0 +1,57 @@
+#-------------------------------------------------------------------------
+#
+# src/tools/pg_bsd_indent/Makefile
+#
+# Copyright (c) 2017-2023, PostgreSQL Global Development Group
+#
+#-------------------------------------------------------------------------
+
+PGFILEDESC = "pg_bsd_indent - indent C code nicely"
+PGAPPICON = win32
+
+subdir = src/tools/pg_bsd_indent
+top_builddir = ../../..
+include $(top_builddir)/src/Makefile.global
+
+override CPPFLAGS := -I$(srcdir) $(CPPFLAGS)
+
+OBJS = \
+ $(WIN32RES) \
+ args.o \
+ err.o \
+ indent.o \
+ io.o \
+ lexi.o \
+ parse.o \
+ pr_comment.o
+
+all: pg_bsd_indent
+
+pg_bsd_indent: $(OBJS) | submake-libpgport
+ $(CC) $(CFLAGS) $^ $(LDFLAGS) $(LDFLAGS_EX) $(LIBS) -o $@$(X)
+
+install: all installdirs
+ $(INSTALL_PROGRAM) pg_bsd_indent$(X) '$(DESTDIR)$(bindir)/pg_bsd_indent$(X)'
+
+installdirs:
+ $(MKDIR_P) '$(DESTDIR)$(bindir)'
+
+uninstall:
+ rm -f '$(DESTDIR)$(bindir)/pg_bsd_indent$(X)'
+
+clean distclean maintainer-clean:
+ rm -f pg_bsd_indent$(X) $(OBJS)
+ rm -rf log/ tmp_check/
+
+check: pg_bsd_indent
+ $(prove_check)
+
+installcheck:
+ $(prove_installcheck)
+
+# Provide this alternate test name to allow testing pg_bsd_indent
+# without building all of the surrounding Postgres installation.
+.PHONY: test
+
+test: pg_bsd_indent
+ $(prove_installcheck)