summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0002-Avoid-linking-to-ncurses.patch25
-rw-r--r--debian/patches/0002-Use-correct-path-to-hciconfig-on-Debian.patch38
-rw-r--r--debian/patches/0003-remove-shebang-from-bash-completion-file.patch18
-rw-r--r--debian/patches/series3
4 files changed, 84 insertions, 0 deletions
diff --git a/debian/patches/0002-Avoid-linking-to-ncurses.patch b/debian/patches/0002-Avoid-linking-to-ncurses.patch
new file mode 100644
index 0000000..fab96b5
--- /dev/null
+++ b/debian/patches/0002-Avoid-linking-to-ncurses.patch
@@ -0,0 +1,25 @@
+From: Sven Joachim <svenjoac@gmx.de>
+Date: Sun, 13 May 2018 09:23:07 +0200
+Subject: Avoid linking to ncurses
+
+---
+ configure.ac | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 2571c5d..b9ef12b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -105,9 +105,9 @@ AC_CHECK_FUNCS([ \
+
+ AC_SEARCH_LIBS([clock_gettime], [rt])
+
+-PKG_CHECK_MODULES([NCURSES], [ncursesw ncurses], [LIBS="$LIBS $ncurses_LIBS"], [
+- AC_SEARCH_LIBS([delwin], [ncursesw ncurses], [], [
+- AC_MSG_ERROR([ncurses is required but was not found])
++PKG_CHECK_MODULES([NCURSES], [ncursesw], [LIBS="$LIBS $ncurses_LIBS"], [
++ AC_SEARCH_LIBS([delwin], [ncursesw], [], [
++ AC_MSG_ERROR([ncursesw is required but was not found])
+ ], [])
+ ])
+
diff --git a/debian/patches/0002-Use-correct-path-to-hciconfig-on-Debian.patch b/debian/patches/0002-Use-correct-path-to-hciconfig-on-Debian.patch
new file mode 100644
index 0000000..5641679
--- /dev/null
+++ b/debian/patches/0002-Use-correct-path-to-hciconfig-on-Debian.patch
@@ -0,0 +1,38 @@
+From: Kan-Ru Chen <kanru@kanru.info>
+Date: Fri, 3 Jan 2020 22:10:51 +0900
+Subject: Use correct path to hciconfig on Debian
+
+Fixes: #772571
+---
+ src/tuning/bluetooth.cpp | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/tuning/bluetooth.cpp b/src/tuning/bluetooth.cpp
+index 2958849..eb50b92 100644
+--- a/src/tuning/bluetooth.cpp
++++ b/src/tuning/bluetooth.cpp
+@@ -46,8 +46,8 @@
+ bt_tunable::bt_tunable(void) : tunable("", 1.0, _("Good"), _("Bad"), _("Unknown"))
+ {
+ sprintf(desc, _("Bluetooth device interface status"));
+- pt_strcpy(toggle_bad, "/usr/sbin/hciconfig hci0 up &> /dev/null &");
+- pt_strcpy(toggle_good, "/usr/sbin/hciconfig hci0 down &> /dev/null");
++ pt_strcpy(toggle_bad, "/bin/hciconfig hci0 up &> /dev/null &");
++ pt_strcpy(toggle_good, "/bin/hciconfig hci0 down &> /dev/null");
+ }
+
+
+@@ -176,11 +176,11 @@ void bt_tunable::toggle(void)
+ good = good_bad();
+
+ if (good == TUNE_GOOD) {
+- if(system("/usr/sbin/hciconfig hci0 up &> /dev/null &"))
++ if(system("/bin/hciconfig hci0 up &> /dev/null &"))
+ printf("System is not available\n");
+ return;
+ }
+- if(system("/usr/sbin/hciconfig hci0 down &> /dev/null"))
++ if(system("/bin/hciconfig hci0 down &> /dev/null"))
+ printf("System is not available\n");
+ }
+
diff --git a/debian/patches/0003-remove-shebang-from-bash-completion-file.patch b/debian/patches/0003-remove-shebang-from-bash-completion-file.patch
new file mode 100644
index 0000000..8ffa14e
--- /dev/null
+++ b/debian/patches/0003-remove-shebang-from-bash-completion-file.patch
@@ -0,0 +1,18 @@
+From: Kan-Ru Chen <kanru@kanru.info>
+Date: Sun, 15 Aug 2021 22:30:26 +0900
+Subject: remove shebang from bash-completion file
+
+---
+ scripts/bash-completion/powertop | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/scripts/bash-completion/powertop b/scripts/bash-completion/powertop
+index 03d238e..4f03a1a 100644
+--- a/scripts/bash-completion/powertop
++++ b/scripts/bash-completion/powertop
+@@ -1,5 +1,3 @@
+-#!/bin/bash
+-#
+ # Powertop tab completion for bash.
+ #
+ # This is part of PowerTOP
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..e36a7de
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+0002-Avoid-linking-to-ncurses.patch
+0002-Use-correct-path-to-hciconfig-on-Debian.patch
+0003-remove-shebang-from-bash-completion-file.patch