summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py53
1 files changed, 53 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..ca2170c
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,53 @@
+#!/usr/bin/env python
+import os
+import re
+
+from setuptools import find_packages, setup
+
+with open(os.path.join(os.path.dirname(__file__), "README.rst")) as f:
+ long_description = f.read()
+
+
+def get_version(package):
+ """
+ Return package version as listed in `__version__` in `__init__.py`.
+ """
+ path = os.path.join(os.path.dirname(__file__), "src", package, "__init__.py")
+ with open(path, "rb") as f:
+ init_py = f.read().decode("utf-8")
+ return re.search("__version__ = ['\"]([^'\"]+)['\"]", init_py).group(1)
+
+
+setup(
+ name="prompt_toolkit",
+ author="Jonathan Slenders",
+ version=get_version("prompt_toolkit"),
+ url="https://github.com/prompt-toolkit/python-prompt-toolkit",
+ description="Library for building powerful interactive command lines in Python",
+ long_description=long_description,
+ long_description_content_type="text/x-rst",
+ packages=find_packages(where="src"),
+ package_dir={"": "src"},
+ package_data={"prompt_toolkit": ["py.typed"]},
+ install_requires=["wcwidth"],
+ # We require Python 3.7, because we need:
+ # - Context variables - PEP 567
+ # - `asyncio.run()`
+ python_requires=">=3.7.0",
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: BSD License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
+ "Programming Language :: Python :: 3.12",
+ "Programming Language :: Python :: 3 :: Only",
+ "Programming Language :: Python",
+ "Topic :: Software Development",
+ ],
+)