summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 13:17:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 13:17:27 +0000
commitcbdb8b64f975172ddd5ec6143a7a2d67301594f9 (patch)
tree15e19a7f041df9d31f7bbea67c1a684274fe9d6c /debian/rules
parentAdding upstream version 23.7. (diff)
downloadpsmisc-debian.tar.xz
psmisc-debian.zip
Adding debian version 23.7-1.debian/23.7-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..2976665
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+
+
+ifeq ($(DEB_BUILD_ARCH_OS),linux)
+CONFIGURE_FLAGS = --enable-selinux
+endif
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- ${CONFIGURE_FLAGS}
+ # Tell blhc to ignore the signal name extraction
+ @echo 'blhc: ignore-line-regexp: .*gcc -E -dM src/signames.c.*'
+
+override_dh_auto_install:
+ dh_auto_install
+ if [ ! -f "debian/psmisc/usr/bin/fuser" ] ; then \
+ rm -f debian/psmisc/usr/share/man/man1/fuser.1 ; \
+ fi
+ if [ "$(DEB_HOST_ARCH_OS)" = "kfreebsd" ] ; then \
+ rm -f debian/psmisc/usr/share/man/man1/peekfd.1 ; \
+ fi