summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..2976665
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+
+
+ifeq ($(DEB_BUILD_ARCH_OS),linux)
+CONFIGURE_FLAGS = --enable-selinux
+endif
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- ${CONFIGURE_FLAGS}
+ # Tell blhc to ignore the signal name extraction
+ @echo 'blhc: ignore-line-regexp: .*gcc -E -dM src/signames.c.*'
+
+override_dh_auto_install:
+ dh_auto_install
+ if [ ! -f "debian/psmisc/usr/bin/fuser" ] ; then \
+ rm -f debian/psmisc/usr/share/man/man1/fuser.1 ; \
+ fi
+ if [ "$(DEB_HOST_ARCH_OS)" = "kfreebsd" ] ; then \
+ rm -f debian/psmisc/usr/share/man/man1/peekfd.1 ; \
+ fi