summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 16:47:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 16:47:43 +0000
commitf1de812cb55b9261be6f5a9f34ff7f6c521ba60e (patch)
tree282581685caaa98f6f8d5ca3e855c46ecf89bcbf
parentReleasing progress-linux version 3.0.26-2~progress7.99u1. (diff)
downloadptpython-f1de812cb55b9261be6f5a9f34ff7f6c521ba60e.tar.xz
ptpython-f1de812cb55b9261be6f5a9f34ff7f6c521ba60e.zip
Merging debian version 3.0.26-3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/debian/0001-platformdirs.patch53
-rw-r--r--debian/patches/series1
3 files changed, 61 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 61f6a62..3b1a378 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+ptpython (3.0.26-3) sid; urgency=medium
+
+ * Uploading to sid.
+ * Migrating from appdirs to platformdirs (Closes: #1067983).
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Sun, 14 Apr 2024 10:23:45 +0200
+
ptpython (3.0.26-2~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/patches/debian/0001-platformdirs.patch b/debian/patches/debian/0001-platformdirs.patch
new file mode 100644
index 0000000..06186e7
--- /dev/null
+++ b/debian/patches/debian/0001-platformdirs.patch
@@ -0,0 +1,53 @@
+Author: Daniel Baumann <daniel.baumann@progress-linux.org>
+Description: Migrating from appdirs to platformdirs (Closes: #1067983).
+
+diff -Naurp ptpython.orig/README.rst ptpython/README.rst
+--- ptpython.orig/README.rst
++++ ptpython/README.rst
+@@ -201,8 +201,8 @@ Configuration
+ *************
+
+ It is possible to create a ``config.py`` file to customize configuration.
+-ptpython will look in an appropriate platform-specific directory via `appdirs
+-<https://pypi.org/project/appdirs/>`. See the ``appdirs`` documentation for the
++ptpython will look in an appropriate platform-specific directory via `platformdirs
++<https://pypi.org/project/platformdirs/>`. See the ``platformdirs`` documentation for the
+ precise location for your platform. A ``PTPYTHON_CONFIG_HOME`` environment
+ variable, if set, can also be used to explicitly override where configuration
+ is looked for.
+diff -Naurp ptpython.orig/ptpython/entry_points/run_ptpython.py ptpython/ptpython/entry_points/run_ptpython.py
+--- ptpython.orig/ptpython/entry_points/run_ptpython.py
++++ ptpython/ptpython/entry_points/run_ptpython.py
+@@ -32,7 +32,7 @@ import sys
+ from textwrap import dedent
+ from typing import IO
+
+-import appdirs
++import platformdirs
+ from prompt_toolkit.formatted_text import HTML
+ from prompt_toolkit.shortcuts import print_formatted_text
+
+@@ -106,9 +106,9 @@ def get_config_and_history_file(namespac
+ """
+ config_dir = os.environ.get(
+ "PTPYTHON_CONFIG_HOME",
+- appdirs.user_config_dir("ptpython", "prompt_toolkit"),
++ platformdirs.user_config_dir("ptpython", "prompt_toolkit"),
+ )
+- data_dir = appdirs.user_data_dir("ptpython", "prompt_toolkit")
++ data_dir = platformdirs.user_data_dir("ptpython", "prompt_toolkit")
+
+ # Create directories.
+ for d in (config_dir, data_dir):
+diff -Naurp ptpython.orig/setup.py ptpython/setup.py
+--- ptpython.orig/setup.py
++++ ptpython/setup.py
+@@ -18,7 +18,7 @@ setup(
+ packages=find_packages("."),
+ package_data={"ptpython": ["py.typed"]},
+ install_requires=[
+- "appdirs",
++ "platformdirs",
+ "importlib_metadata;python_version<'3.8'",
+ "jedi>=0.16.0",
+ # Use prompt_toolkit 3.0.34, because of `OneStyleAndTextTuple` import.
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..f0ceaa0
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+debian/0001-platformdirs.patch