summaryrefslogtreecommitdiffstats
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 05:17:02 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 05:17:02 +0000
commit90762dda6bc343cc68c736ec0e4368b2909c2a12 (patch)
tree522fbd669fac12e8db704af129aaf91b6e9dfa96 /.pre-commit-config.yaml
parentReleasing progress-linux version 4.1.12-1~progress7.99u1. (diff)
downloadpython-ansible-compat-90762dda6bc343cc68c736ec0e4368b2909c2a12.tar.xz
python-ansible-compat-90762dda6bc343cc68c736ec0e4368b2909c2a12.zip
Merging upstream version 24.5.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml20
1 files changed, 10 insertions, 10 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 57030ab..e8fed89 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -22,7 +22,7 @@ exclude: |
)$
repos:
- repo: https://github.com/astral-sh/ruff-pre-commit
- rev: "v0.2.0"
+ rev: "v0.4.3"
hooks:
- id: ruff
args: [--fix, --exit-non-zero-on-fix]
@@ -40,7 +40,7 @@ repos:
- prettier-plugin-toml
- prettier-plugin-sort-json
- repo: https://github.com/pre-commit/pre-commit-hooks.git
- rev: v4.5.0
+ rev: v4.6.0
hooks:
- id: end-of-file-fixer
- id: trailing-whitespace
@@ -60,19 +60,19 @@ repos:
hooks:
- id: codespell
- repo: https://github.com/adrienverge/yamllint.git
- rev: v1.33.0
+ rev: v1.35.1
hooks:
- id: yamllint
files: \.(yaml|yml)$
types: [file, yaml]
entry: yamllint --strict
- repo: https://github.com/psf/black
- rev: 24.1.1
+ rev: 24.4.2
hooks:
- id: black
language_version: python3
- repo: https://github.com/pre-commit/mirrors-mypy
- rev: v1.8.0
+ rev: v1.10.0
hooks:
- id: mypy
# empty args needed in order to match mypy cli behavior
@@ -89,7 +89,7 @@ repos:
- types-pkg_resources
- types-jsonschema>=4.4.9
- repo: https://github.com/pycqa/pylint
- rev: v3.0.3
+ rev: v3.1.0
hooks:
- id: pylint
additional_dependencies:
@@ -104,20 +104,20 @@ repos:
name: Upgrade constraints files and requirements
files: ^(pyproject\.toml|requirements\.txt)$
language: python
- entry: python -m piptools compile --resolver=backtracking --upgrade -q --strip-extras --extra docs --extra test --output-file=requirements.txt pyproject.toml --unsafe-package ansible-core --unsafe-package resolvelib --unsafe-package typing_extensions
+ entry: python3 -m piptools compile --resolver=backtracking --upgrade -q --strip-extras --all-extras --output-file=.config/constraints.txt pyproject.toml --unsafe-package ansible-core --unsafe-package resolvelib --unsafe-package typing_extensions
pass_filenames: false
stages:
- manual
additional_dependencies:
- - pip-tools>=6.11.0
+ - pip-tools>=7.4.1
- id: pip-compile
name: Check constraints files and requirements
files: ^(pyproject\.toml|requirements\.txt)$
language: python
- entry: python -m piptools compile --resolver=backtracking -q --strip-extras --extra docs --extra test --output-file=requirements.txt pyproject.toml --unsafe-package ansible-core --unsafe-package resolvelib --unsafe-package typing_extensions
+ entry: python3 -m piptools compile --resolver=backtracking -q --strip-extras --all-extras --output-file=.config/constraints.txt pyproject.toml --unsafe-package ansible-core --unsafe-package resolvelib --unsafe-package typing_extensions
pass_filenames: false
additional_dependencies:
- - pip-tools>=6.11.0
+ - pip-tools>=7.4.1
- repo: https://github.com/packit/pre-commit-hooks
rev: v1.2.0
hooks: