summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 00:31:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 00:31:49 +0000
commitee8af66d2b0e49e30b75d5f9932807a127f6c942 (patch)
tree36d4dd94c247396cadf50ad9287dc1d8b6e4bf8b
parentMerging upstream version 4.1.12. (diff)
downloadpython-ansible-compat-ee8af66d2b0e49e30b75d5f9932807a127f6c942.tar.xz
python-ansible-compat-ee8af66d2b0e49e30b75d5f9932807a127f6c942.zip
Merging debian version 4.1.12-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog10
-rw-r--r--debian/control1
-rw-r--r--debian/patches/001.skip-test-error.patch101
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules9
-rw-r--r--debian/tests/control3
6 files changed, 17 insertions, 108 deletions
diff --git a/debian/changelog b/debian/changelog
index 968132b..de1f56f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+python-ansible-compat (4.1.12-1) unstable; urgency=medium
+
+ * New upstream version 4.1.12
+ * debian/control: Added suite autopkgtest
+ * debian/patches: Remove unnecessary patches
+ * debian/rules: changed test disable mode
+ * debian/tests: replaced by autopkgtest from debian/control
+
+ -- Josenilson Ferreira da Silva <nilsonfsilva@hotmail.com> Sat, 06 Apr 2024 08:46:03 -0300
+
python-ansible-compat (4.1.11-1~progress7.99u1) graograman-backports; urgency=medium
* Initial reupload to graograman-backports.
diff --git a/debian/control b/debian/control
index 6523a49..e5b048f 100644
--- a/debian/control
+++ b/debian/control
@@ -23,6 +23,7 @@ Vcs-Git: https://git.progress-linux.org/packages/graograman-backports/python-ans
XSBC-Original-Vcs-Browser: https://salsa.debian.org/python-team/packages/python-ansible-compat
XSBC-Original-Vcs-Git: https://salsa.debian.org/python-team/packages/python-ansible-compat.git
Rules-Requires-Root: no
+Testsuite: autopkgtest-pkg-pybuild
Package: python3-ansible-compat
Architecture: all
diff --git a/debian/patches/001.skip-test-error.patch b/debian/patches/001.skip-test-error.patch
deleted file mode 100644
index 199e787..0000000
--- a/debian/patches/001.skip-test-error.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-Description: skip function with error
-Author: Josenilson Ferreira da silva <nilsonfsilva@hotmail.com>
-Forwarded: not-needed
-Last-Update: 2022-09-02
-Index: python-ansible-compat/test/test_runtime.py
-===================================================================
---- python-ansible-compat.orig/test/test_runtime.py
-+++ python-ansible-compat/test/test_runtime.py
-@@ -239,7 +239,7 @@ def cwd(path: Path) -> Iterator[None]:
- finally:
- os.chdir(old_pwd)
-
--
-+@pytest.mark.skip(reason="unknown error")
- def test_prerun_reqs_v1(caplog: pytest.LogCaptureFixture) -> None:
- """Checks that the linter can auto-install requirements v1 when found."""
- runtime = Runtime(verbosity=1)
-@@ -254,7 +254,7 @@ def test_prerun_reqs_v1(caplog: pytest.L
- for msg in caplog.messages
- )
-
--
-+@pytest.mark.skip(reason="unknown error")
- def test_prerun_reqs_v2(caplog: pytest.LogCaptureFixture) -> None:
- """Checks that the linter can auto-install requirements v2 when found."""
- runtime = Runtime(verbosity=1)
-@@ -398,7 +398,7 @@ def test__update_env(
-
- assert runtime.environ["DUMMY_VAR"] == result
-
--
-+@pytest.mark.skip(reason="unknown error")
- def test_require_collection_wrong_version(runtime: Runtime) -> None:
- """Tests behaviour of require_collection."""
- subprocess.check_output(
-@@ -477,7 +477,7 @@ def test_install_collection(runtime: Run
- """Check that valid collection installs do not fail."""
- runtime.install_collection("examples/reqs_v2/community-molecule-0.1.0.tar.gz")
-
--
-+@pytest.mark.skip(reason="unknown error")
- def test_install_collection_git(runtime: Runtime) -> None:
- """Check that valid collection installs do not fail."""
- runtime.install_collection(
-@@ -525,7 +525,7 @@ def test_install_galaxy_role(runtime_tmp
- ):
- runtime_tmp._install_galaxy_role(runtime_tmp.project_dir, role_name_check=0)
-
--
-+@pytest.mark.skip(reason="unknown error")
- def test_install_galaxy_role_unlink(
- caplog: pytest.LogCaptureFixture,
- ) -> None:
-@@ -686,6 +686,8 @@ def test_runtime_version_in_range(
- ),
- ),
- )
-+
-+@pytest.mark.skip(reason="unknown error")
- def test_install_collection_from_disk(
- path: str,
- scenario: str,
-@@ -772,7 +774,7 @@ def test_runtime_exec_env(runtime: Runti
- result = runtime.run(["printenv", "FOO"])
- assert result.stdout.rstrip() == "bar"
-
--
-+@pytest.mark.skip(reason="unknown error")
- def test_runtime_plugins(runtime: Runtime) -> None:
- """Tests ability to access detected plugins."""
- assert len(runtime.plugins.cliconf) == 0
-@@ -863,7 +865,7 @@ def test_is_url(name: str, result: bool)
- """Checks functionality of is_url."""
- assert is_url(name) == result
-
--
-+@pytest.mark.skip(reason="unknown error")
- def test_prepare_environment_repair_broken_symlink(
- caplog: pytest.LogCaptureFixture,
- ) -> None:
-@@ -885,6 +887,7 @@ def test_prepare_environment_repair_brok
- )
-
-
-+@pytest.mark.skip(reason="unknown error")
- def test_get_galaxy_role_name_invalid() -> None:
- """Verifies that function returns empty string on invalid input."""
- galaxy_infos = {
-Index: python-ansible-compat/test/test_runtime_scan_path.py
-===================================================================
---- python-ansible-compat.orig/test/test_runtime_scan_path.py
-+++ python-ansible-compat/test/test_runtime_scan_path.py
-@@ -42,6 +42,8 @@ class ScanSysPath:
- ),
- ids=str,
- )
-+
-+@pytest.mark.skip(reason="unknown error")
- def test_scan_sys_path(
- venv_module: VirtualEnvironment,
- monkeypatch: MonkeyPatch,
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 4db4a60..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1 +0,0 @@
-001.skip-test-error.patch
diff --git a/debian/rules b/debian/rules
index 2e14189..013d75e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,9 +1,12 @@
#!/usr/bin/make -f
#export DH_VERBOSE = 1
-%:
- dh $@ --with python3 --buildsystem=pybuild
#tests are failing due to an incompatibility between ansible galaxy and
#python-resolvelib:
## https://github.com/ansible/ansible/issues/77624
-override_dh_auto_test:
+export PYBUILD_DISABLE=test
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+#override_dh_auto_test:
diff --git a/debian/tests/control b/debian/tests/control
deleted file mode 100644
index 58d1355..0000000
--- a/debian/tests/control
+++ /dev/null
@@ -1,3 +0,0 @@
-Test-Command: python3 -m pytest -v -k 'not test_runtime_scan_path.py'
-Depends: @, python3-pytest, python3-all, python3-pytest-mock
-Restrictions: allow-stderr