summaryrefslogtreecommitdiffstats
path: root/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:07:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:07:41 +0000
commit76926159194e180003aa78de97e5f287bf4325a5 (patch)
tree2cea7245cdc3f66355900c820c145eba90598766 /README.md
parentInitial commit. (diff)
downloadpython-apt-76926159194e180003aa78de97e5f287bf4325a5.tar.xz
python-apt-76926159194e180003aa78de97e5f287bf4325a5.zip
Adding upstream version 2.7.6.upstream/2.7.6
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'README.md')
-rw-r--r--README.md49
1 files changed, 49 insertions, 0 deletions
diff --git a/README.md b/README.md
new file mode 100644
index 0000000..a3ea8aa
--- /dev/null
+++ b/README.md
@@ -0,0 +1,49 @@
+# Python-apt is a wrapper to use features of apt from python.
+
+It contains the following modules:
+
+## C++ Wrapper:
+
+* apt_pkg - access to libapt-pkg (wrapper to the lowlevel c++ code)
+* apt_inst - access to libapt-inst (wrapper to the lowlevel c++ code)
+
+## Python module:
+
+* apt - high level python interface build on top of apt_pkg, apt_inst
+* aptsources - high level manipulation of sources.list
+
+
+# Development
+
+## Building
+
+To build python-apt run:
+```
+$ python setup.py build
+```
+You may need to install the build-dependencies via:
+```
+$ sudo apt build-dep ./
+```
+first.
+
+## Running the tests
+
+Run the tests with:
+```
+$ python tests/test_all.py
+$ python3 tests/test_all.py
+```
+
+## Running mypy:
+
+To check if the "apt" python module is mypy clean, run:
+```
+$ MYPYPATH=./typehinting/ mypy ./apt
+```
+
+To use the annotation with your source code, run:
+```
+$ MYPYPATH=/usr/lib/python3/dist-packages/apt mypy ./my-program
+```
+(adjust from python3 to python2.7 if you run there).