summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:19:53 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:19:53 +0000
commitf42a25756b9133ae9c62fa7a86112bfc603391c8 (patch)
tree51bf1ba3aad37d5913d230724bd1969d4d466286 /debian/rules
parentAdding upstream version 0.91.0. (diff)
downloadpython-ruyaml-f42a25756b9133ae9c62fa7a86112bfc603391c8.tar.xz
python-ruyaml-f42a25756b9133ae9c62fa7a86112bfc603391c8.zip
Adding debian version 0.91.0-3.debian/0.91.0-3debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules26
1 files changed, 26 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..6c8b9ee
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+#export DH_VERBOSE = 1
+
+export PYBUILD_NAME=ruyaml
+export PYBUILD_BEFORE_TEST=cp -a {dir}/_test {build_dir}
+export PYBUILD_AFTER_TEST=rm -rf {build_dir}/_test
+
+include /usr/share/dpkg/pkg-info.mk
+
+BUILD_DATE = $(shell LC_ALL=C date -u "+%d %B %Y" -d "@$(SOURCE_DATE_EPOCH)")
+SPHINXOPTS := -N -D html_last_updated_fmt="$(BUILD_DATE)"
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_clean:
+ dh_clean
+ rm -rf .mypy_cache
+
+override_dh_sphinxdoc:
+ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
+ PYTHONPATH=. python3 -m sphinx -b html $(SPHINXOPTS) _doc $(CURDIR)/debian/python-ruyaml-doc/usr/share/doc/python-ruyaml-doc/html
+ dh_sphinxdoc
+endif