summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:19:53 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:19:53 +0000
commite7ee850d46d54789979bf0c5244bae1825fb7149 (patch)
tree6e94ed55df9ec749682a3c792ce752d07892b968 /pyproject.toml
parentInitial commit. (diff)
downloadpython-ruyaml-e7ee850d46d54789979bf0c5244bae1825fb7149.tar.xz
python-ruyaml-e7ee850d46d54789979bf0c5244bae1825fb7149.zip
Adding upstream version 0.91.0.upstream/0.91.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..0472fb0
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,27 @@
+[build-system]
+requires = [
+ "pip >= 19.3.1",
+ "setuptools >= 42",
+ "setuptools_scm[toml] >= 3.5.0",
+ "setuptools_scm_git_archive >= 1.1",
+ "wheel >= 0.33.6",
+]
+build-backend = "setuptools.build_meta"
+
+[tool.black]
+skip-string-normalization = true
+
+[tool.isort]
+profile = "black"
+# known_first_party = "foo"
+
+[tool.pytest.ini_options]
+# ensure we treat warnings as error
+filterwarnings = [
+ # "error",
+ "error::DeprecationWarning",
+ "error::PendingDeprecationWarning"
+]
+
+[tool.setuptools_scm]
+local_scheme = "no-local-version"