summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:40:54 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:40:54 +0000
commit0336e3b7a97fe9ab118065eff0b25fad507a9a50 (patch)
treee49702ccec26f0ace090ed80ad22ec9a4a8975ab /debian/rules
parentAdding upstream version 5:7.2.4. (diff)
downloadredis-0336e3b7a97fe9ab118065eff0b25fad507a9a50.tar.xz
redis-0336e3b7a97fe9ab118065eff0b25fad507a9a50.zip
Adding debian version 5:7.2.4-1.debian/5%7.2.4-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules50
1 files changed, 50 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b3510b9
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,50 @@
+#!/usr/bin/make -f
+
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+
+export BUILD_TLS = yes
+export CFLAGS CPPFLAGS LDFLAGS
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_CFLAGS_MAINT_APPEND = -I/usr/include/liblzf
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-no-as-needed -ldl -latomic -llzf
+
+# Build jemelloc in parallel
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ MAKEFLAGS += -j$(NUMJOBS)
+ export MAKEFLAGS
+endif
+
+%:
+ dh $@
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -f src/release.h debian/*.service
+
+override_dh_auto_build:
+ dh_auto_build -- V=1 USE_SYSTEM_JEMALLOC=yes USE_SYSTEMD=yes USE_JEMALLOC=yes
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ # Generate a root CA and server certificate for testing
+ ./utils/gen-test-certs.sh
+ # Avoid race conditions in upstream testsuite
+ ./runtest --clients 1 --verbose --dump-logs --tls || true
+ timeout 30m ./runtest-cluster --tls || true
+ ./runtest-sentinel || true
+ # Clean up after gen-test-certs.sh
+ rm -rf tests/tls || true
+ # Other cleanup
+ find tests/tmp ! -name .gitignore -type f -exec rm -rfv {} +
+endif
+
+override_dh_auto_install:
+ debian/bin/generate-systemd-service-files
+
+override_dh_compress:
+ dh_compress -Xredis-trib.rb
+
+override_dh_installchangelogs:
+ dh_installchangelogs --keep 00-RELEASENOTES