summaryrefslogtreecommitdiffstats
path: root/deps/fpconv/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:40:54 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:40:54 +0000
commit317c0644ccf108aa23ef3fd8358bd66c2840bfc0 (patch)
treec417b3d25c86b775989cb5ac042f37611b626c8a /deps/fpconv/Makefile
parentInitial commit. (diff)
downloadredis-317c0644ccf108aa23ef3fd8358bd66c2840bfc0.tar.xz
redis-317c0644ccf108aa23ef3fd8358bd66c2840bfc0.zip
Adding upstream version 5:7.2.4.upstream/5%7.2.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'deps/fpconv/Makefile')
-rw-r--r--deps/fpconv/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/deps/fpconv/Makefile b/deps/fpconv/Makefile
new file mode 100644
index 0000000..2654888
--- /dev/null
+++ b/deps/fpconv/Makefile
@@ -0,0 +1,27 @@
+STD=
+WARN= -Wall
+OPT= -Os
+
+R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
+R_LDFLAGS= $(LDFLAGS)
+DEBUG= -g
+
+R_CC=$(CC) $(R_CFLAGS)
+R_LD=$(CC) $(R_LDFLAGS)
+
+AR= ar
+ARFLAGS= rcs
+
+libfpconv.a: fpconv_dtoa.o
+ $(AR) $(ARFLAGS) $@ $+
+
+fpconv_dtoa.o: fpconv_dtoa.h fpconv_dtoa.c
+
+.c.o:
+ $(R_CC) -c $<
+
+clean:
+ rm -f *.o
+ rm -f *.a
+
+