summaryrefslogtreecommitdiffstats
path: root/deps/linenoise/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:40:54 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:40:54 +0000
commit317c0644ccf108aa23ef3fd8358bd66c2840bfc0 (patch)
treec417b3d25c86b775989cb5ac042f37611b626c8a /deps/linenoise/Makefile
parentInitial commit. (diff)
downloadredis-317c0644ccf108aa23ef3fd8358bd66c2840bfc0.tar.xz
redis-317c0644ccf108aa23ef3fd8358bd66c2840bfc0.zip
Adding upstream version 5:7.2.4.upstream/5%7.2.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'deps/linenoise/Makefile')
-rw-r--r--deps/linenoise/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/deps/linenoise/Makefile b/deps/linenoise/Makefile
new file mode 100644
index 0000000..1dd894b
--- /dev/null
+++ b/deps/linenoise/Makefile
@@ -0,0 +1,21 @@
+STD=
+WARN= -Wall
+OPT= -Os
+
+R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
+R_LDFLAGS= $(LDFLAGS)
+DEBUG= -g
+
+R_CC=$(CC) $(R_CFLAGS)
+R_LD=$(CC) $(R_LDFLAGS)
+
+linenoise.o: linenoise.h linenoise.c
+
+linenoise_example: linenoise.o example.o
+ $(R_LD) -o $@ $^
+
+.c.o:
+ $(R_CC) -c $<
+
+clean:
+ rm -f linenoise_example *.o