summaryrefslogtreecommitdiffstats
path: root/src/external_tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/external_tools/CMakeLists.txt')
-rw-r--r--src/external_tools/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/external_tools/CMakeLists.txt b/src/external_tools/CMakeLists.txt
new file mode 100644
index 0000000..f7b17cf
--- /dev/null
+++ b/src/external_tools/CMakeLists.txt
@@ -0,0 +1,44 @@
+# desktop/remmina - The GTK+ Remote Desktop Client
+#
+# Copyright (C) 2011 Marc-Andre Moreau
+# Copyright (C) 2014-2023 Antenore Gatta, Giovanni Panozzo
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+#
+# In addition, as a special exception, the copyright holders give
+# permission to link the code of portions of this program with the
+# OpenSSL library under certain conditions as described in each
+# individual source file, and distribute linked combinations
+# including the two.
+# You must obey the GNU General Public License in all respects
+# for all of the code used other than OpenSSL. If you modify
+# file(s) with this exception, you may extend this exception to your
+# version of the file(s), but you are not obligated to do so. If you
+# do not wish to do so, delete this exception statement from your
+# version. If you delete this exception statement from all source
+# files in the program, then also delete it here.
+
+INSTALL(PROGRAMS
+ launcher.sh
+ functions.sh
+ remmina_filezilla_sftp.sh
+ remmina_filezilla_sftp_pki.sh
+ remmina_nslookup.sh
+ remmina_ping.sh
+ remmina_traceroute.sh
+ DESTINATION ${REMMINA_EXTERNAL_TOOLS_DIR})
+
+