summaryrefslogtreecommitdiffstats
path: root/.cirrus.yml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 19:22:07 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 19:22:07 +0000
commitb842d8449361bc56b30d781084fa829824607082 (patch)
tree772be8bd6ac3d7c5bc2709b6c5859c5aff7ed4b2 /.cirrus.yml
parentAdding debian version 0.17.0-3. (diff)
downloadrnp-b842d8449361bc56b30d781084fa829824607082.tar.xz
rnp-b842d8449361bc56b30d781084fa829824607082.zip
Merging upstream version 0.17.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.cirrus.yml')
-rw-r--r--.cirrus.yml8
1 files changed, 4 insertions, 4 deletions
diff --git a/.cirrus.yml b/.cirrus.yml
index 0d0115f..2fd7d95 100644
--- a/.cirrus.yml
+++ b/.cirrus.yml
@@ -23,7 +23,7 @@
# POSSIBILITY OF SUCH DAMAGE.
freebsd_instance:
- image: freebsd-12-3-release-amd64
+ image: freebsd-13-2-release-amd64
task:
name: build
@@ -31,9 +31,9 @@ task:
skip: "!changesInclude('.cirrus.yml') && changesIncludeOnly('/*.sh', '/.*', '/_*', 'Brewfile', 'docs/**', '**.adoc', '**.md', '**.nix', 'flake.lock', '.github/**') || $CIRRUS_CHANGE_MESSAGE =~ '.*skip ci.*'"
env:
matrix:
- - { CIRRUS_CLONE_SUBMODULES: true, CRYPTO_BACKEND: openssl, CRYPTO_LIB_INSTALL: openssl, SHARED_LIBS: on }
- - { CIRRUS_CLONE_SUBMODULES: true, CRYPTO_BACKEND: botan, CRYPTO_LIB_INSTALL: botan2, SHARED_LIBS: on }
- - { CIRRUS_CLONE_SUBMODULES: true, CRYPTO_BACKEND: botan, CRYPTO_LIB_INSTALL: botan2, SHARED_LIBS: off }
+ - { CIRRUS_CLONE_SUBMODULES: true, CRYPTO_BACKEND: openssl, CRYPTO_LIB_INSTALL: openssl, SHARED_LIBS: on, RNP_LOG_CONSOLE: 1 }
+ - { CIRRUS_CLONE_SUBMODULES: true, CRYPTO_BACKEND: botan, CRYPTO_LIB_INSTALL: botan2, SHARED_LIBS: on, RNP_LOG_CONSOLE: 1 }
+ - { CIRRUS_CLONE_SUBMODULES: true, CRYPTO_BACKEND: botan, CRYPTO_LIB_INSTALL: botan2, SHARED_LIBS: off, RNP_LOG_CONSOLE: 1 }
dependencies_script: |
pkg install -y gcc cmake pkgconf googletest gnupg $CRYPTO_LIB_INSTALL json-c rubygem-asciidoctor