summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..c9ddc20
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,26 @@
+{
+ description = "High performance C++ OpenPGP library, fully compliant to RFC 4880";
+
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = { self, nixpkgs, flake-utils }:
+ flake-utils.lib.eachDefaultSystem (system:
+ let
+ pkgs = nixpkgs.legacyPackages.${system};
+ thePackage = pkgs.callPackage ./default.nix { };
+ in
+ rec {
+ defaultApp = flake-utils.lib.mkApp {
+ drv = defaultPackage;
+ };
+ defaultPackage = thePackage;
+ devShell = pkgs.mkShell {
+ buildInputs = [
+ thePackage
+ ];
+ };
+ });
+} \ No newline at end of file