summaryrefslogtreecommitdiffstats
path: root/contrib/xxhash/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/xxhash/CMakeLists.txt')
-rw-r--r--contrib/xxhash/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/contrib/xxhash/CMakeLists.txt b/contrib/xxhash/CMakeLists.txt
new file mode 100644
index 0000000..fa69efb
--- /dev/null
+++ b/contrib/xxhash/CMakeLists.txt
@@ -0,0 +1,13 @@
+SET(XXHASHSRC xxhash.c)
+
+ADD_LIBRARY(xxhash STATIC ${XXHASHSRC})
+
+IF(ENABLE_FULL_DEBUG MATCHES "OFF")
+if ("${CMAKE_C_COMPILER_ID}" STREQUAL "Clang" OR "${CMAKE_C_COMPILER_ID}" STREQUAL "GNU")
+ SET_TARGET_PROPERTIES(xxhash PROPERTIES COMPILE_FLAGS "-O3")
+endif ()
+else()
+ADD_DEFINITIONS(-DXXH_NO_INLINE_HINTS=1)
+ENDIF()
+
+set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DXXH_NO_INLINE_HINTS=1" PARENT_SCOPE)