summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a8edd68
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@
+
+# Disable ASM optimizations (--disable-md5-asm).
+# This is not needed because the ASM-optimized implementation
+# available is the MD5 hash, which is actually a no-op because we link
+# against OpenSSL and rsync ends up using that library's
+# implementation of the hash. Even then, the final binary ends up
+# with the ASM-optimized version included, which makes it become
+# CET-incompatible.
+# Don't use bundled zlib (with-included-zlib=no).
+override_dh_auto_configure:
+ dh_auto_configure -- --with-included-zlib=no --disable-md5-asm --with-rrsync
+
+override_dh_installsystemd:
+ dh_installsystemd --no-enable