summaryrefslogtreecommitdiffstats
path: root/contrib/fmhash/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 16:28:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 16:28:20 +0000
commitdcc721a95bef6f0d8e6d8775b8efe33e5aecd562 (patch)
tree66a2774cd0ee294d019efd71d2544c70f42b2842 /contrib/fmhash/Makefile.am
parentInitial commit. (diff)
downloadrsyslog-dcc721a95bef6f0d8e6d8775b8efe33e5aecd562.tar.xz
rsyslog-dcc721a95bef6f0d8e6d8775b8efe33e5aecd562.zip
Adding upstream version 8.2402.0.upstream/8.2402.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib/fmhash/Makefile.am')
-rw-r--r--contrib/fmhash/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/contrib/fmhash/Makefile.am b/contrib/fmhash/Makefile.am
new file mode 100644
index 0000000..d16e121
--- /dev/null
+++ b/contrib/fmhash/Makefile.am
@@ -0,0 +1,8 @@
+#
+# fmhash support
+#
+pkglib_LTLIBRARIES = fmhash.la
+fmhash_la_SOURCES = fmhash.c
+fmhash_la_CPPFLAGS = $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
+fmhash_la_LDFLAGS = -module -avoid-version
+fmhash_la_LIBADD = $(HASH_XXHASH_LIBS)