summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 00:47:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 00:47:48 +0000
commit22f9a9dcf2f6c45b227a5cb5067627b13c7ed68e (patch)
treed1fdee9281831316b9606149b70b809020c697f5
parentMerging upstream version 0.2.8+ds. (diff)
downloadruamel.yaml.clib-22f9a9dcf2f6c45b227a5cb5067627b13c7ed68e.tar.xz
ruamel.yaml.clib-22f9a9dcf2f6c45b227a5cb5067627b13c7ed68e.zip
Merging debian version 0.2.8+ds-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog9
-rw-r--r--debian/control7
-rw-r--r--debian/copyright2
-rwxr-xr-xdebian/get-hg-version47
-rw-r--r--debian/patches/import-pxd.patch14
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules29
-rw-r--r--debian/tests/control7
-rw-r--r--debian/watch7
9 files changed, 97 insertions, 26 deletions
diff --git a/debian/changelog b/debian/changelog
index 81eb7c5..afe00a4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+ruamel.yaml.clib (0.2.8+ds-1) unstable; urgency=medium
+
+ * Team upload
+ * Download source from SourceForge, including Cython files
+ * Reintroduce build-dependency on cython3, and rebuild C file from
+ source before compiling
+
+ -- Julian Gilbey <jdg@debian.org> Thu, 18 Apr 2024 05:34:49 +0100
+
ruamel.yaml.clib (0.2.8-2~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/control b/debian/control
index 6aaa6b1..482b882 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,8 @@ XSBC-Uploaders: Daniel Baumann <daniel.baumann@progress-linux.org>
XSBC-Original-Maintainer: Debian Python Team <team+python@tracker.debian.org>
XSBC-Original-Uploaders: Michael R. Crusoe <crusoe@debian.org>
Bugs: mailto:maintainers@lists.progress-linux.org
-Build-Depends: debhelper-compat (= 13),
+Build-Depends: cython3,
+ debhelper-compat (= 13),
dh-python,
pybuild-plugin-pyproject,
python3-all-dev,
@@ -22,7 +23,9 @@ Rules-Requires-Root: no
Package: python3-ruamel.yaml.clib
Architecture: any
Multi-Arch: same
-Depends: ${shlibs:Depends}, ${misc:Depends}, ${python3:Depends}
+Depends: ${misc:Depends},
+ ${python3:Depends},
+ ${shlibs:Depends}
Breaks: python3-ruamel.yaml (<< 0.18.6)
Replaces: python3-ruamel.yaml (<< 0.16.10)
Description: C version of reader, parser and emitter for ruamel.yaml
diff --git a/debian/copyright b/debian/copyright
index 001047d..882c689 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,6 +1,8 @@
Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: ruamel.yaml.clib
+Upstream-Contact: Anthon van der Neut <a.van.der.neut@ruamel.eu>
Source: https://sourceforge.net/p/ruamel-yaml-clib/code/ci/default/tree
+Comment: Cloned and repacked from SourceForge repository
Files: *
Copyright: 2019, Anthon van der Neut, Ruamel bvba <a.van.der.neut@ruamel.eu>
diff --git a/debian/get-hg-version b/debian/get-hg-version
new file mode 100755
index 0000000..efe508c
--- /dev/null
+++ b/debian/get-hg-version
@@ -0,0 +1,47 @@
+#!/bin/bash
+
+# This script is called by uscan(1) as:
+# get-hg-version --upstream-version <version>
+
+# We create a temporary directory, clone the upstream repository into it,
+# check out the current upstream version, tar this directory, and then
+# copy it to the parent directory in place of the existing downloaded
+# .orig.tar.gz file.
+
+if [ "$1" != "--upstream-version" ]
+then
+ echo "Script called with unexpected arguments: $*" >&2
+ echo "Expected $0 --upstream-version <uversion>" >&2
+ exit 1
+fi
+
+if ! hg --version > /dev/null
+then
+ echo 'Need to install the "mercurial" package to run uscan on ruamel.yaml.clib' >&2
+ exit 1
+fi
+
+PACKAGE=ruamel.yaml.clib
+PACKAGE_DASH=ruamel-yaml-clib
+PWD=$(pwd)
+cd ..
+PPWD=$(pwd)
+TMP=$(mktemp -d)
+trap "rm -rf '$TMP'" INT QUIT TERM EXIT
+
+uversion=$2
+cd "$TMP"
+
+hg clone http://hg.code.sf.net/p/${PACKAGE_DASH}/code $PACKAGE-$uversion
+cd $PACKAGE-$uversion
+hg update $uversion
+cd ..
+mv $PACKAGE-$uversion $PACKAGE-$uversion+ds
+tar Jcpf ${PACKAGE}_$uversion+ds.orig.tar.xz --exclude=.hg $PACKAGE-$uversion+ds
+rm -f "$PPWD"/${PACKAGE}_$uversion.orig.tar.gz
+mv ${PACKAGE}_$uversion+ds.orig.tar.xz "$PPWD"
+cd "$PWD"
+rm -rf "$TMP"
+
+trap - INT QUIT TERM EXIT
+
diff --git a/debian/patches/import-pxd.patch b/debian/patches/import-pxd.patch
new file mode 100644
index 0000000..13e1099
--- /dev/null
+++ b/debian/patches/import-pxd.patch
@@ -0,0 +1,14 @@
+Description: Explicitly import all of _ruamel_yaml.pxd
+ Without this, cython fails to compile the file.
+Forwarded: https://sourceforge.net/p/ruamel-yaml-clib/tickets/35/
+Author: Julian Gilbey <jdg@debian.org>
+Last-Update: 2024-04-17
+
+--- a/_ruamel_yaml.pyx
++++ b/_ruamel_yaml.pyx
+@@ -1,4 +1,4 @@
+-
++from _ruamel_yaml cimport *
+
+ def get_version_string():
+ cdef char *value
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..f285d14
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+import-pxd.patch
diff --git a/debian/rules b/debian/rules
index f6203d8..c0581b0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,30 +1,25 @@
#!/usr/bin/make -f
export PYBUILD_NAME=ruamel.yaml.clib
-export RUAMEL_NO_PIP_INSTALL_CHECK=True
-#PYBUILD_INSTALL_ARGS=--single-version-externally-managed
+export PYBUILD_INSTALL_ARGS=--single-version-externally-managed
# DH_VERBOSE := 1
export LC_ALL=C.UTF-8
-include /usr/share/dpkg/default.mk
-# this provides:
-# DEB_SOURCE: the source package name
-# DEB_VERSION: the full version of the package (epoch + upstream vers. + revision)
-# DEB_VERSION_EPOCH_UPSTREAM: the package's version without the Debian revision
-# DEB_VERSION_UPSTREAM_REVISION: the package's version without the Debian epoch
-# DEB_VERSION_UPSTREAM: the package's upstream version
-# DEB_DISTRIBUTION: the distribution(s) listed in the current entry of debian/changelog
-# SOURCE_DATE_EPOCH: the source release date as seconds since the epoch, as
-# specified by <https://reproducible-builds.org/specs/source-date-epoch/>
-
# for hardening you might like to uncomment this:
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
%:
dh $@ --with python3 --buildsystem=pybuild
-override_dh_auto_test:
-ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- echo "There is no test suite available"
-endif
+execute_before_dh_auto_build:
+ # We cannot run cython in a directory with a non-valid Python name
+ mkdir ruamel.yaml.clib
+ cp _ruamel_yaml.[hp]* yaml.h ruamel.yaml.clib
+ cd ruamel.yaml.clib && cython -3 -I . _ruamel_yaml.pyx
+ mv _ruamel_yaml.c _ruamel_yaml.c.orig
+ mv ruamel.yaml.clib/_ruamel_yaml.c .
+
+execute_after_dh_auto_build:
+ mv _ruamel_yaml.c.orig _ruamel_yaml.c
+ rm -rf ruamel.yaml.clib
diff --git a/debian/tests/control b/debian/tests/control
index 84ec838..1509238 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,6 +1,5 @@
Tests: smoke
-Depends:
- python3-all,
- python3-pytest,
- python3-ruamel.yaml (>= 0.18.6),
+Depends: python3-all,
+ python3-pytest,
+ python3-ruamel.yaml (>= 0.18.6)
Restrictions: superficial, allow-stderr
diff --git a/debian/watch b/debian/watch
index 37eaad6..327edf8 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,4 +1,5 @@
version=4
-
-opts=uversionmangle=s/(rc|a|b|c)/~$1/ \
-https://pypi.debian.net/ruamel.yaml.clib/ruamel.yaml.clib-@ANY_VERSION@@ARCHIVE_EXT@
+opts="dversionmangle=auto" \
+https://pypi.python.org/packages/source/r/ruamel.yaml.clib/ \
+ ruamel.yaml.clib-@ANY_VERSION@@ARCHIVE_EXT@ \
+ debian debian/get-hg-version