summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 00:46:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 00:46:58 +0000
commitae556d46aaf4fcf7e48fbbf9cfe223a87255fab0 (patch)
treee4da9a2c3bb60d9d66a036e63a0bb69f5949e13a
parentReleasing progress-linux version 0.2.8-1~progress7.99u1. (diff)
downloadruamel.yaml.clib-ae556d46aaf4fcf7e48fbbf9cfe223a87255fab0.tar.xz
ruamel.yaml.clib-ae556d46aaf4fcf7e48fbbf9cfe223a87255fab0.zip
Merging debian version 0.2.8-2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog9
-rw-r--r--debian/control5
-rw-r--r--debian/tests/control2
-rw-r--r--debian/tests/data/test-yaml.py6
4 files changed, 15 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index d6ac72f..304f41a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+ruamel.yaml.clib (0.2.8-2) unstable; urgency=medium
+
+ * Team upload
+ * Update Debian autopkgtests for newer version of ruamel.yaml
+ * Bump Standards-Version to 4.7.0, no changes needed
+ * Drop unnecessary build-dependency on cython3
+
+ -- Julian Gilbey <jdg@debian.org> Mon, 15 Apr 2024 13:55:43 +0100
+
ruamel.yaml.clib (0.2.8-1~progress7.99u1) graograman-backports; urgency=medium
* Initial reupload to graograman-backports.
diff --git a/debian/control b/debian/control
index 94275fc..6aaa6b1 100644
--- a/debian/control
+++ b/debian/control
@@ -8,11 +8,10 @@ XSBC-Original-Uploaders: Michael R. Crusoe <crusoe@debian.org>
Bugs: mailto:maintainers@lists.progress-linux.org
Build-Depends: debhelper-compat (= 13),
dh-python,
- cython3,
pybuild-plugin-pyproject,
python3-all-dev,
python3-setuptools
-Standards-Version: 4.6.2
+Standards-Version: 4.7.0
Vcs-Browser: https://git.progress-linux.org/packages/graograman-backports/ruamel.yaml.clib
Vcs-Git: https://git.progress-linux.org/packages/graograman-backports/ruamel.yaml.clib
XSBC-Original-Vcs-Browser: https://salsa.debian.org/python-team/packages/ruamel.yaml.clib
@@ -24,7 +23,7 @@ Package: python3-ruamel.yaml.clib
Architecture: any
Multi-Arch: same
Depends: ${shlibs:Depends}, ${misc:Depends}, ${python3:Depends}
-Breaks: python3-ruamel.yaml (<< 0.16.10)
+Breaks: python3-ruamel.yaml (<< 0.18.6)
Replaces: python3-ruamel.yaml (<< 0.16.10)
Description: C version of reader, parser and emitter for ruamel.yaml
This package was split of from ruamel.yaml, so that ruamel.yaml can be build
diff --git a/debian/tests/control b/debian/tests/control
index 30f529a..84ec838 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -2,5 +2,5 @@ Tests: smoke
Depends:
python3-all,
python3-pytest,
- python3-ruamel.yaml,
+ python3-ruamel.yaml (>= 0.18.6),
Restrictions: superficial, allow-stderr
diff --git a/debian/tests/data/test-yaml.py b/debian/tests/data/test-yaml.py
index 7a1bf9e..311a3f8 100644
--- a/debian/tests/data/test-yaml.py
+++ b/debian/tests/data/test-yaml.py
@@ -1,15 +1,15 @@
# very crude smoke test of the yaml package
-import ruamel.yaml as yaml
+from ruamel.yaml import YAML
def test_load_clib():
import ruamel.yaml.cyaml
def test_safe_load():
-
+ yaml = YAML(typ="safe", pure=False)
with open("test-yaml.yaml") as fh:
- y = yaml.safe_load(fh)
+ y = yaml.load(fh)
assert len(y['testdata']) == 2