diff options
author | Daniel Baumann <daniel.baumann@progress-linux.org> | 2024-05-04 00:47:29 +0000 |
---|---|---|
committer | Daniel Baumann <daniel.baumann@progress-linux.org> | 2024-05-04 00:47:29 +0000 |
commit | fd0ae3eca1c986a6b97da2fba8934ef44342b3c5 (patch) | |
tree | fe18c4c9e56e9a3368b53f0ac4494a9a55cf09ca /tox.ini | |
parent | Releasing progress-linux version 0.2.8-2~progress7.99u1. (diff) | |
download | ruamel.yaml.clib-fd0ae3eca1c986a6b97da2fba8934ef44342b3c5.tar.xz ruamel.yaml.clib-fd0ae3eca1c986a6b97da2fba8934ef44342b3c5.zip |
Merging upstream version 0.2.8+ds.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tox.ini')
-rwxr-xr-x | tox.ini | 52 |
1 files changed, 52 insertions, 0 deletions
@@ -0,0 +1,52 @@ +[tox] +toxworkdir = /data1/DATA/tox/ruamel.yaml.clib +envlist = cs,py311,py310,py39,py38,py37,py312,py36 + +[testenv] +allowlist_externals = /bin/bash +install_command = pip install --disable-pip-version-check {opts} {packages} +skip_install = True +commands = + python setup.py bdist_wheel -d /data1/DATA/tox/ruamel.yaml.clib/dist/ + pip install --upgrade --find-links=/data1/DATA/tox/ruamel.yaml.clib/dist/ ruamel.yaml.clib +deps = + pytest + setuptools + wheel + +[testenv:cs] +basepython = python3.11 +deps = + flake8 + flake8-bugbear;python_version>="3.11" + flake8-2020==1.8.1 + flake8-commas==2.1.0 + flake8-comprehensions==3.14.0 + flake8-length==0.3.1 + flake8-logging-format==0.9.0 +commands = + flake8 []{posargs} + +[testenv:pep8] +basepython = python3.11 +deps = + flake8 + flake8-bugbear;python_version>="3.11" + flake8-2020==1.8.1 + flake8-commas==2.1.0 + flake8-comprehensions==3.14.0 + flake8-length==0.3.1 + flake8-logging-format==0.9.0 +commands = + flake8 []{posargs} + +[flake8] +show-source = True +max-line-length = 95 +ignore = W503,F405,E203,C408 +exclude = .hg,.git,.tox,dist,.cache,__pycache__,ruamel.zip2tar.egg-info + +[pytest] +filterwarnings = + error::DeprecationWarning + error::PendingDeprecationWarning |