summaryrefslogtreecommitdiffstats
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rwxr-xr-xtox.ini52
1 files changed, 52 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
new file mode 100755
index 0000000..0651bd2
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,52 @@
+[tox]
+toxworkdir = /data1/DATA/tox/ruamel.yaml.clib
+envlist = cs,py311,py310,py39,py38,py37,py312,py36
+
+[testenv]
+allowlist_externals = /bin/bash
+install_command = pip install --disable-pip-version-check {opts} {packages}
+skip_install = True
+commands =
+ python setup.py bdist_wheel -d /data1/DATA/tox/ruamel.yaml.clib/dist/
+ pip install --upgrade --find-links=/data1/DATA/tox/ruamel.yaml.clib/dist/ ruamel.yaml.clib
+deps =
+ pytest
+ setuptools
+ wheel
+
+[testenv:cs]
+basepython = python3.11
+deps =
+ flake8
+ flake8-bugbear;python_version>="3.11"
+ flake8-2020==1.8.1
+ flake8-commas==2.1.0
+ flake8-comprehensions==3.14.0
+ flake8-length==0.3.1
+ flake8-logging-format==0.9.0
+commands =
+ flake8 []{posargs}
+
+[testenv:pep8]
+basepython = python3.11
+deps =
+ flake8
+ flake8-bugbear;python_version>="3.11"
+ flake8-2020==1.8.1
+ flake8-commas==2.1.0
+ flake8-comprehensions==3.14.0
+ flake8-length==0.3.1
+ flake8-logging-format==0.9.0
+commands =
+ flake8 []{posargs}
+
+[flake8]
+show-source = True
+max-line-length = 95
+ignore = W503,F405,E203,C408
+exclude = .hg,.git,.tox,dist,.cache,__pycache__,ruamel.zip2tar.egg-info
+
+[pytest]
+filterwarnings =
+ error::DeprecationWarning
+ error::PendingDeprecationWarning