summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rwxr-xr-xdebian/get-hg-version8
3 files changed, 14 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 28972d3..2fe8a72 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+ruamel.yaml (0.18.6-2) unstable; urgency=medium
+
+ * Team upload.
+ * Fix autopkgtests in ruamel.yaml.clib and depend on that version
+
+ -- Julian Gilbey <jdg@debian.org> Mon, 15 Apr 2024 14:04:05 +0100
+
ruamel.yaml (0.18.6-1~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/control b/debian/control
index 9706a60..f71146d 100644
--- a/debian/control
+++ b/debian/control
@@ -23,7 +23,7 @@ Rules-Requires-Root: no
Package: python3-ruamel.yaml
Architecture: all
-Depends: python3-ruamel.yaml.clib,
+Depends: python3-ruamel.yaml.clib (>= 0.2.8-2),
${misc:Depends},
${python3:Depends}
Recommends: ${python3:Recommends}
diff --git a/debian/get-hg-version b/debian/get-hg-version
index 4e3f60e..d548a78 100755
--- a/debian/get-hg-version
+++ b/debian/get-hg-version
@@ -8,8 +8,6 @@
# copy it to the parent directory in place of the existing downloaded
# .orig.tar.gz file.
-# set -e
-
if [ "$1" != "--upstream-version" ]
then
echo "Script called with unexpected arguments: $*" >&2
@@ -17,6 +15,12 @@ then
exit 1
fi
+if ! hg --version > /dev/null
+then
+ echo 'Need to install the "mercurial" package to run uscan on ruamel.yaml' >&2
+ exit 1
+fi
+
PWD=$(pwd)
cd ..
PPWD=$(pwd)