summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..fe19b82
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+%:
+ dh $@ --buildsystem cargo
+
+override_dh_auto_test:
+ dh_auto_test -- test --all
+
+override_dh_installman:
+ help2man debian/cbindgen/usr/bin/cbindgen > debian/cbindgen.1
+ dh_installman -O--buildsystem=cargo
+
+execute_after_dh_testdir:
+ find . ! -newermt "jan 01, 2000" -exec touch {} +