summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml36
1 files changed, 32 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index fffeedd..23b1648 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,11 +13,15 @@
edition = "2021"
rust-version = "1.56"
name = "proc-macro2"
-version = "1.0.81"
+version = "1.0.85"
authors = [
"David Tolnay <dtolnay@gmail.com>",
"Alex Crichton <alex@alexcrichton.com>",
]
+build = "build.rs"
+autobins = false
+autoexamples = false
+autotests = false
autobenches = false
description = "A substitute implementation of the compiler's `proc_macro` API to decouple token-based libraries from the procedural macro use case."
documentation = "https://docs.rs/proc-macro2"
@@ -38,8 +42,6 @@ rustc-args = [
rustdoc-args = [
"--cfg",
"procmacro2_semver_exempt",
- "--cfg",
- "doc_cfg",
"--generate-link-to-definition",
]
targets = ["x86_64-unknown-linux-gnu"]
@@ -48,8 +50,34 @@ targets = ["x86_64-unknown-linux-gnu"]
features = ["span-locations"]
[lib]
+name = "proc_macro2"
+path = "src/lib.rs"
doc-scrape-examples = false
+[[test]]
+name = "comments"
+path = "tests/comments.rs"
+
+[[test]]
+name = "test_fmt"
+path = "tests/test_fmt.rs"
+
+[[test]]
+name = "features"
+path = "tests/features.rs"
+
+[[test]]
+name = "marker"
+path = "tests/marker.rs"
+
+[[test]]
+name = "test_size"
+path = "tests/test_size.rs"
+
+[[test]]
+name = "test"
+path = "tests/test.rs"
+
[dependencies.unicode-ident]
version = "1.0"
@@ -58,7 +86,7 @@ version = "1.0"
[dev-dependencies.quote]
version = "1.0"
-default_features = false
+default-features = false
[dev-dependencies.rayon]
version = "1.0"