summaryrefslogtreecommitdiffstats
path: root/debian/control
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:06:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:06:37 +0000
commit246f239d9f40f633160f0c18f87a20922d4e77bb (patch)
tree5a88572663584b3d4d28e5a20e10abab1be40884 /debian/control
parentReleasing progress-linux version 1.64.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-246f239d9f40f633160f0c18f87a20922d4e77bb.tar.xz
rustc-246f239d9f40f633160f0c18f87a20922d4e77bb.zip
Merging debian version 1.65.0+dfsg1-2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control30
1 files changed, 15 insertions, 15 deletions
diff --git a/debian/control b/debian/control
index abaf245fe..f466d8a2d 100644
--- a/debian/control
+++ b/debian/control
@@ -17,13 +17,13 @@ Build-Depends:
dpkg-dev (>= 1.17.14),
python3:native,
cargo:native (>= 0.60.0) <!pkg.rustc.dlstage0>,
- rustc:native (>= 1.63.0+dfsg) <!pkg.rustc.dlstage0>,
- rustc:native (<= 1.64.0++) <!pkg.rustc.dlstage0>,
- llvm-14-dev:native,
- llvm-14-tools:native,
+ rustc:native (>= 1.64.0+dfsg) <!pkg.rustc.dlstage0>,
+ rustc:native (<= 1.65.0++) <!pkg.rustc.dlstage0>,
+ llvm-15-dev:native,
+ llvm-15-tools:native,
gcc-mingw-w64-x86-64-posix:native [amd64] <!nowindows>,
gcc-mingw-w64-i686-posix:native [i386] <!nowindows>,
- libllvm14 (>= 1:14.0.0),
+ libllvm15 (>= 1:15.0.0),
cmake (>= 3.0) | cmake3,
# needed by some vendor crates
pkg-config,
@@ -44,7 +44,7 @@ Build-Depends:
Build-Depends-Indep:
wasi-libc (>= 0.0~git20220510.9886d3d~~) <!nowasm>,
wasi-libc (<= 0.0~git20220510.9886d3d++) <!nowasm>,
- clang-14:native,
+ clang-15:native,
Build-Conflicts: gdb-minimal <!nocheck>
Standards-Version: 4.2.1
Homepage: http://www.rust-lang.org/
@@ -61,12 +61,12 @@ Depends: ${shlibs:Depends}, ${misc:Depends},
libstd-rust-dev (= ${binary:Version}),
gcc, libc-dev, binutils (>= 2.26)
Recommends:
- cargo (>= 0.65.0~~), cargo (<< 0.66.0~~),
+ cargo (>= 0.66.0~~), cargo (<< 0.67.0~~),
# llvm is needed for llvm-dwp for -C split-debuginfo=packed
- llvm-14,
+ llvm-15,
Suggests:
# lld and clang are needed for wasm compilation
- lld-14, clang-14,
+ lld-15, clang-15,
Replaces: libstd-rust-dev (<< 1.25.0+dfsg1-2~~)
Breaks: libstd-rust-dev (<< 1.25.0+dfsg1-2~~)
Description: Rust systems programming language
@@ -82,7 +82,7 @@ Description: Rust systems programming language
generic programming and meta-programming, in both static and dynamic
styles.
-Package: libstd-rust-1.64
+Package: libstd-rust-1.65
Section: libs
Architecture: any
Multi-Arch: same
@@ -109,7 +109,7 @@ Section: libdevel
Architecture: any
Multi-Arch: same
Depends: ${shlibs:Depends}, ${misc:Depends},
- libstd-rust-1.64 (= ${binary:Version}),
+ libstd-rust-1.65 (= ${binary:Version}),
Description: Rust standard libraries - development files
Rust is a curly-brace, block-structured expression language. It
visually resembles the C language family, but differs significantly
@@ -161,7 +161,7 @@ Depends: ${shlibs:Depends}, ${misc:Depends}
# Embeds wasi-libc so doesn't need to depend on it
# None of its licenses require source redistrib, so no need for Built-Using
Recommends:
- lld-14, clang-14,
+ lld-15, clang-15,
Suggests:
# nodejs contains wasi-node for running the program
nodejs (>= 12.16),
@@ -207,7 +207,7 @@ Description: Rust debugger (gdb)
Package: rust-lldb
Architecture: all
# When updating, also update rust-lldb.links
-Depends: lldb-14, ${misc:Depends}, python3-lldb-14
+Depends: lldb-15, ${misc:Depends}, python3-lldb-15
Replaces: rustc (<< 1.1.0+dfsg1-1)
Description: Rust debugger (lldb)
Rust is a curly-brace, block-structured expression language. It
@@ -272,7 +272,7 @@ Package: rust-clippy
Architecture: any
Multi-Arch: allowed
Depends: ${misc:Depends}, ${shlibs:Depends},
- libstd-rust-1.64 (= ${binary:Version})
+ libstd-rust-1.65 (= ${binary:Version})
Recommends: cargo
Description: Rust linter
Rust is a curly-brace, block-structured expression language. It
@@ -327,7 +327,7 @@ Depends: ${misc:Depends}, ${shlibs:Depends},
rust-gdb (>= ${binary:Version}) | rust-lldb (>= ${binary:Version}),
cargo,
Recommends:
- cargo (>= 0.65.0~~), cargo (<< 0.66.0~~)
+ cargo (>= 0.66.0~~), cargo (<< 0.67.0~~)
Suggests:
rust-doc (>= ${binary:Version}),
rust-src (>= ${binary:Version}),