summaryrefslogtreecommitdiffstats
path: root/debian/control
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 04:04:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 04:04:52 +0000
commit2bbd74a6bb04bb919e4391350ca93daf965450f5 (patch)
treebd68876c4f219286193a04699ec81104a8e489ad /debian/control
parentMerging upstream version 1.73.0+dfsg1. (diff)
downloadrustc-2bbd74a6bb04bb919e4391350ca93daf965450f5.tar.xz
rustc-2bbd74a6bb04bb919e4391350ca93daf965450f5.zip
Merging debian version 1.73.0+dfsg1-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control34
1 files changed, 17 insertions, 17 deletions
diff --git a/debian/control b/debian/control
index 9c6f46643..b7bbc418e 100644
--- a/debian/control
+++ b/debian/control
@@ -16,15 +16,15 @@ Build-Depends:
debhelper-compat (= 13),
dpkg-dev (>= 1.17.14),
python3:native,
- cargo:native (>= 1.71.0+dfsg) <!pkg.rustc.dlstage0>,
- rustc:native (>= 1.71.0+dfsg) <!pkg.rustc.dlstage0>,
- rustc:native (<= 1.72.1++) <!pkg.rustc.dlstage0>,
- llvm-16-dev:native,
- llvm-16-tools:native,
+ cargo:native (>= 1.72.0+dfsg) <!pkg.rustc.dlstage0>,
+ rustc:native (>= 1.72.0+dfsg) <!pkg.rustc.dlstage0>,
+ rustc:native (<= 1.73.0++) <!pkg.rustc.dlstage0>,
+ llvm-17-dev:native,
+ llvm-17-tools:native,
gcc-mingw-w64-x86-64-posix:native [amd64] <!nowindows>,
gcc-mingw-w64-i686-posix:native [i386] <!nowindows>,
- libllvm16 (>= 1:16.0.0),
- libclang-rt-16-dev:native,
+ libllvm17t64 (>= 1:17.0.0),
+ libclang-rt-17-dev:native,
cmake (>= 3.0),
# needed by some vendor crates
pkgconf,
@@ -52,9 +52,9 @@ Build-Depends:
curl <pkg.rustc.dlstage0>,
ca-certificates <pkg.rustc.dlstage0>,
Build-Depends-Indep:
- wasi-libc (>= 0.0~git20230621.7018e24~~) <!nowasm>,
- wasi-libc (<= 0.0~git20230621.7018e24++) <!nowasm>,
- clang-16:native,
+ wasi-libc (>= 0.0~git20230821.ec4566b~~) <!nowasm>,
+ wasi-libc (<= 0.0~git20230821.ec4566b++) <!nowasm>,
+ clang-17:native,
Build-Conflicts: gdb-minimal <!nocheck>
Standards-Version: 4.6.2
Homepage: http://www.rust-lang.org/
@@ -89,7 +89,7 @@ Description: Rust systems programming language
generic programming and meta-programming, in both static and dynamic
styles.
-Package: libstd-rust-1.72
+Package: libstd-rust-1.73
Section: libs
Architecture: any
Multi-Arch: same
@@ -116,7 +116,7 @@ Section: libdevel
Architecture: any
Multi-Arch: same
Depends: ${shlibs:Depends}, ${misc:Depends},
- libstd-rust-1.72 (= ${binary:Version}),
+ libstd-rust-1.73 (= ${binary:Version}),
Description: Rust standard libraries - development files
Rust is a curly-brace, block-structured expression language. It
visually resembles the C language family, but differs significantly
@@ -168,7 +168,7 @@ Depends: ${shlibs:Depends}, ${misc:Depends}
# Embeds wasi-libc so doesn't need to depend on it
# None of its licenses require source redistrib, so no need for Built-Using
Recommends:
- lld-16, clang-16,
+ lld-17, clang-17,
Suggests:
# nodejs contains wasi-node for running the program
nodejs (>= 12.16),
@@ -214,7 +214,7 @@ Description: Rust debugger (gdb)
Package: rust-lldb
Architecture: all
# When updating, also update rust-lldb.links
-Depends: lldb-16, ${misc:Depends}, python3-lldb-16
+Depends: lldb-17, ${misc:Depends}, python3-lldb-17
Replaces: rustc (<< 1.1.0+dfsg1-1)
Description: Rust debugger (lldb)
Rust is a curly-brace, block-structured expression language. It
@@ -245,9 +245,9 @@ Replaces:
Depends:
${misc:Depends},
# lld and clang are needed for wasm compilation
- lld-16, clang-16,
+ lld-17, clang-17,
# llvm is needed for llvm-dwp for split-debuginfo=packed
- llvm-16
+ llvm-17
Description: Rust LLVM integration
Rust is a curly-brace, block-structured expression language. It
visually resembles the C language family, but differs significantly
@@ -311,7 +311,7 @@ Package: rust-clippy
Architecture: any
Multi-Arch: allowed
Depends: ${misc:Depends}, ${shlibs:Depends},
- libstd-rust-1.72 (= ${binary:Version})
+ libstd-rust-1.73 (= ${binary:Version})
Recommends: cargo
Description: Rust linter
Rust is a curly-brace, block-structured expression language. It