summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-0005-no-jemalloc.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-19 09:26:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-19 09:26:37 +0000
commit1c69ecb2dd463a5cd922e872386381e1cc17147e (patch)
treed49e9c5086b704151975474cb9ae68509ffa4787 /debian/patches/d-0005-no-jemalloc.patch
parentMerging upstream version 1.76.0+dfsg1. (diff)
downloadrustc-1c69ecb2dd463a5cd922e872386381e1cc17147e.tar.xz
rustc-1c69ecb2dd463a5cd922e872386381e1cc17147e.zip
Merging debian version 1.76.0+dfsg1-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/d-0005-no-jemalloc.patch')
-rw-r--r--debian/patches/d-0005-no-jemalloc.patch48
1 files changed, 0 insertions, 48 deletions
diff --git a/debian/patches/d-0005-no-jemalloc.patch b/debian/patches/d-0005-no-jemalloc.patch
deleted file mode 100644
index 1ff501dc3..000000000
--- a/debian/patches/d-0005-no-jemalloc.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
-Date: Sat, 2 Oct 2021 01:08:00 +0100
-Subject: d-0005-no-jemalloc
-
----
- compiler/rustc/Cargo.toml | 6 ------
- src/tools/rust-analyzer/crates/profile/Cargo.toml | 2 --
- 2 files changed, 8 deletions(-)
-
-diff --git a/compiler/rustc/Cargo.toml b/compiler/rustc/Cargo.toml
-index 3cb56a7..af37dfc 100644
---- a/compiler/rustc/Cargo.toml
-+++ b/compiler/rustc/Cargo.toml
-@@ -20,14 +20,8 @@ rustc_smir = { path = "../rustc_smir" }
- stable_mir = { path = "../stable_mir" }
- # tidy-alphabetical-end
-
--[dependencies.jemalloc-sys]
--version = "0.5.0"
--optional = true
--features = ['unprefixed_malloc_on_supported_platforms']
--
- [features]
- # tidy-alphabetical-start
--jemalloc = ['jemalloc-sys']
- llvm = ['rustc_driver_impl/llvm']
- max_level_info = ['rustc_driver_impl/max_level_info']
- rustc_use_parallel_compiler = ['rustc_driver_impl/rustc_use_parallel_compiler']
-diff --git a/src/tools/rust-analyzer/crates/profile/Cargo.toml b/src/tools/rust-analyzer/crates/profile/Cargo.toml
-index 937834a..fd98d85 100644
---- a/src/tools/rust-analyzer/crates/profile/Cargo.toml
-+++ b/src/tools/rust-analyzer/crates/profile/Cargo.toml
-@@ -17,7 +17,6 @@ cfg-if = "1.0.0"
- libc = "0.2.135"
- la-arena.workspace = true
- countme = { version = "3.0.1", features = ["enable"] }
--jemalloc-ctl = { version = "0.5.0", package = "tikv-jemalloc-ctl", optional = true }
-
- [target.'cfg(target_os = "linux")'.dependencies]
- perf-event = "=0.4.7"
-@@ -27,7 +26,6 @@ winapi = { version = "0.3.9", features = ["processthreadsapi", "psapi"] }
-
- [features]
- cpu_profiler = []
--jemalloc = ["jemalloc-ctl"]
-
- # Uncomment to enable for the whole crate graph
- # default = [ "cpu_profiler" ]