summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:06:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:06:37 +0000
commit246f239d9f40f633160f0c18f87a20922d4e77bb (patch)
tree5a88572663584b3d4d28e5a20e10abab1be40884 /debian/rules
parentReleasing progress-linux version 1.64.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-246f239d9f40f633160f0c18f87a20922d4e77bb.tar.xz
rustc-246f239d9f40f633160f0c18f87a20922d4e77bb.zip
Merging debian version 1.65.0+dfsg1-2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 8 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 8b83b8272..97f2f071d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,8 +28,8 @@ export RUST_LONG_VERSION
DEB_DESTDIR := $(CURDIR)/debian/tmp
# Use system LLVM (comment out to use vendored LLVM)
-LLVM_VERSION = 14
-OLD_LLVM_VERSION = 13
+LLVM_VERSION = 15
+OLD_LLVM_VERSION = 14
# Make it easier to test against a custom LLVM
ifneq (,$(LLVM_DESTDIR))
LLVM_LIBRARY_PATH := $(LLVM_DESTDIR)/usr/lib/$(DEB_HOST_MULTIARCH):$(LLVM_DESTDIR)/usr/lib
@@ -278,9 +278,14 @@ FAILURES_ALLOWED = 8
ifneq (,$(filter $(DEB_BUILD_ARCH), armhf))
FAILURES_ALLOWED = 12
endif
-ifneq (,$(filter $(DEB_BUILD_ARCH), armel mips mipsel mips64el))
+ifneq (,$(filter $(DEB_BUILD_ARCH), armel mips mips64el))
FAILURES_ALLOWED = 24
endif
+# workaround broken gdb 13.1 - revert to 24 once fixed
+# #1031946 / #1032785
+ifneq (,$(filter $(DEB_BUILD_ARCH), mipsel))
+ FAILURES_ALLOWED = 25
+endif
ifneq (,$(filter $(DEB_BUILD_ARCH), ppc64 s390x))
FAILURES_ALLOWED = 40
endif