summaryrefslogtreecommitdiffstats
path: root/library/backtrace/crates
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
commitef24de24a82fe681581cc130f342363c47c0969a (patch)
tree0d494f7e1a38b95c92426f58fe6eaa877303a86c /library/backtrace/crates
parentReleasing progress-linux version 1.74.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-ef24de24a82fe681581cc130f342363c47c0969a.tar.xz
rustc-ef24de24a82fe681581cc130f342363c47c0969a.zip
Merging upstream version 1.75.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'library/backtrace/crates')
-rw-r--r--library/backtrace/crates/as-if-std/Cargo.toml4
-rw-r--r--library/backtrace/crates/debuglink/Cargo.toml2
-rw-r--r--library/backtrace/crates/dylib-dep/Cargo.toml2
-rw-r--r--library/backtrace/crates/line-tables-only/Cargo.toml2
-rw-r--r--library/backtrace/crates/line-tables-only/src/lib.rs15
-rw-r--r--library/backtrace/crates/macos_frames_test/Cargo.toml2
-rw-r--r--library/backtrace/crates/without_debuginfo/Cargo.toml2
7 files changed, 15 insertions, 14 deletions
diff --git a/library/backtrace/crates/as-if-std/Cargo.toml b/library/backtrace/crates/as-if-std/Cargo.toml
index bcbcfe159..7f12cfb56 100644
--- a/library/backtrace/crates/as-if-std/Cargo.toml
+++ b/library/backtrace/crates/as-if-std/Cargo.toml
@@ -2,7 +2,7 @@
name = "as-if-std"
version = "0.1.0"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
-edition = "2018"
+edition = "2021"
publish = false
[lib]
@@ -24,7 +24,7 @@ addr2line = { version = "0.21.0", optional = true, default-features = false }
version = "0.32.0"
default-features = false
optional = true
-features = ['read_core', 'elf', 'macho', 'pe', 'unaligned', 'archive']
+features = ['read_core', 'elf', 'macho', 'pe', 'xcoff', 'unaligned', 'archive']
[build-dependencies]
# Dependency of the `backtrace` crate
diff --git a/library/backtrace/crates/debuglink/Cargo.toml b/library/backtrace/crates/debuglink/Cargo.toml
index 6b55b1394..5e62abd37 100644
--- a/library/backtrace/crates/debuglink/Cargo.toml
+++ b/library/backtrace/crates/debuglink/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "debuglink"
version = "0.1.0"
-edition = "2018"
+edition = "2021"
[dependencies]
backtrace = { path = "../.." }
diff --git a/library/backtrace/crates/dylib-dep/Cargo.toml b/library/backtrace/crates/dylib-dep/Cargo.toml
index c3d4a8c2f..e6cc9c23b 100644
--- a/library/backtrace/crates/dylib-dep/Cargo.toml
+++ b/library/backtrace/crates/dylib-dep/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "dylib-dep"
version = "0.1.0"
-edition = "2018"
+edition = "2021"
authors = []
publish = false
diff --git a/library/backtrace/crates/line-tables-only/Cargo.toml b/library/backtrace/crates/line-tables-only/Cargo.toml
index e2967d3d3..8d17db58c 100644
--- a/library/backtrace/crates/line-tables-only/Cargo.toml
+++ b/library/backtrace/crates/line-tables-only/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "line-tables-only"
version = "0.1.0"
-edition = "2018"
+edition = "2021"
[build-dependencies]
cc = "1.0"
diff --git a/library/backtrace/crates/line-tables-only/src/lib.rs b/library/backtrace/crates/line-tables-only/src/lib.rs
index bd5afcb3a..b292b8441 100644
--- a/library/backtrace/crates/line-tables-only/src/lib.rs
+++ b/library/backtrace/crates/line-tables-only/src/lib.rs
@@ -1,8 +1,8 @@
#[cfg(test)]
mod tests {
- use std::path::Path;
use backtrace::Backtrace;
use libc::c_void;
+ use std::path::Path;
pub type Callback = extern "C" fn(data: *mut c_void);
@@ -15,11 +15,12 @@ mod tests {
unsafe { *(data as *mut Option<Backtrace>) = Some(bt) };
}
- fn assert_contains(backtrace: &Backtrace,
- expected_name: &str,
- expected_file: &str,
- expected_line: u32) {
-
+ fn assert_contains(
+ backtrace: &Backtrace,
+ expected_name: &str,
+ expected_file: &str,
+ expected_line: u32,
+ ) {
let expected_file = Path::new(expected_file);
for frame in backtrace.frames() {
@@ -34,7 +35,7 @@ mod tests {
}
}
- panic!("symbol {:?} not found in backtrace: {:?}", expected_name, backtrace);
+ panic!("symbol {expected_name:?} not found in backtrace: {backtrace:?}");
}
/// Verifies that when debug info includes only lines tables the generated
diff --git a/library/backtrace/crates/macos_frames_test/Cargo.toml b/library/backtrace/crates/macos_frames_test/Cargo.toml
index 278d51e79..849e76414 100644
--- a/library/backtrace/crates/macos_frames_test/Cargo.toml
+++ b/library/backtrace/crates/macos_frames_test/Cargo.toml
@@ -2,7 +2,7 @@
name = "macos_frames_test"
version = "0.1.0"
authors = ["Aaron Hill <aa1ronham@gmail.com>"]
-edition = "2018"
+edition = "2021"
[dependencies.backtrace]
path = "../.."
diff --git a/library/backtrace/crates/without_debuginfo/Cargo.toml b/library/backtrace/crates/without_debuginfo/Cargo.toml
index 19d76cbec..38e559971 100644
--- a/library/backtrace/crates/without_debuginfo/Cargo.toml
+++ b/library/backtrace/crates/without_debuginfo/Cargo.toml
@@ -2,7 +2,7 @@
name = "without_debuginfo"
version = "0.1.0"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
-edition = "2018"
+edition = "2021"
[dependencies.backtrace]
path = "../.."