summaryrefslogtreecommitdiffstats
path: root/library/rustc-std-workspace-alloc
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /library/rustc-std-workspace-alloc
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'library/rustc-std-workspace-alloc')
-rw-r--r--library/rustc-std-workspace-alloc/Cargo.toml14
-rw-r--r--library/rustc-std-workspace-alloc/lib.rs9
2 files changed, 23 insertions, 0 deletions
diff --git a/library/rustc-std-workspace-alloc/Cargo.toml b/library/rustc-std-workspace-alloc/Cargo.toml
new file mode 100644
index 000000000..049ca3e46
--- /dev/null
+++ b/library/rustc-std-workspace-alloc/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+name = "rustc-std-workspace-alloc"
+version = "1.99.0"
+license = 'MIT OR Apache-2.0'
+description = """
+Hack for the compiler's own build system
+"""
+edition = "2021"
+
+[lib]
+path = "lib.rs"
+
+[dependencies]
+alloc = { path = "../alloc" }
diff --git a/library/rustc-std-workspace-alloc/lib.rs b/library/rustc-std-workspace-alloc/lib.rs
new file mode 100644
index 000000000..c38a8d2f2
--- /dev/null
+++ b/library/rustc-std-workspace-alloc/lib.rs
@@ -0,0 +1,9 @@
+#![feature(no_core)]
+#![no_core]
+
+// See rustc-std-workspace-core for why this crate is needed.
+
+// Rename the crate to avoid conflicting with the alloc module in liballoc.
+extern crate alloc as foo;
+
+pub use foo::*;