summaryrefslogtreecommitdiffstats
path: root/library/rustc-std-workspace-std
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /library/rustc-std-workspace-std
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'library/rustc-std-workspace-std')
-rw-r--r--library/rustc-std-workspace-std/Cargo.toml14
-rw-r--r--library/rustc-std-workspace-std/README.md3
-rw-r--r--library/rustc-std-workspace-std/lib.rs2
3 files changed, 19 insertions, 0 deletions
diff --git a/library/rustc-std-workspace-std/Cargo.toml b/library/rustc-std-workspace-std/Cargo.toml
new file mode 100644
index 000000000..3a1dc2a02
--- /dev/null
+++ b/library/rustc-std-workspace-std/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+name = "rustc-std-workspace-std"
+version = "1.99.0"
+license = 'MIT OR Apache-2.0'
+description = """
+Hack for the compiler's own build system
+"""
+edition = "2021"
+
+[lib]
+path = "lib.rs"
+
+[dependencies]
+std = { path = "../std" }
diff --git a/library/rustc-std-workspace-std/README.md b/library/rustc-std-workspace-std/README.md
new file mode 100644
index 000000000..2228907f3
--- /dev/null
+++ b/library/rustc-std-workspace-std/README.md
@@ -0,0 +1,3 @@
+# The `rustc-std-workspace-std` crate
+
+See documentation for the `rustc-std-workspace-core` crate.
diff --git a/library/rustc-std-workspace-std/lib.rs b/library/rustc-std-workspace-std/lib.rs
new file mode 100644
index 000000000..1e955c61a
--- /dev/null
+++ b/library/rustc-std-workspace-std/lib.rs
@@ -0,0 +1,2 @@
+#![feature(restricted_std)]
+pub use std::*;