summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/c-link-to-rust-dylib/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /src/test/run-make-fulldeps/c-link-to-rust-dylib/Makefile
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/c-link-to-rust-dylib/Makefile')
-rw-r--r--src/test/run-make-fulldeps/c-link-to-rust-dylib/Makefile17
1 files changed, 0 insertions, 17 deletions
diff --git a/src/test/run-make-fulldeps/c-link-to-rust-dylib/Makefile b/src/test/run-make-fulldeps/c-link-to-rust-dylib/Makefile
deleted file mode 100644
index 2a371b545..000000000
--- a/src/test/run-make-fulldeps/c-link-to-rust-dylib/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-include ../tools.mk
-
-all: $(TMPDIR)/$(call BIN,bar)
- $(call RUN,bar)
- $(call REMOVE_DYLIBS,foo)
- $(call FAIL,bar)
-
-ifdef IS_MSVC
-$(TMPDIR)/$(call BIN,bar): $(call DYLIB,foo)
- $(CC) bar.c $(TMPDIR)/foo.dll.lib $(call OUT_EXE,bar)
-else
-$(TMPDIR)/$(call BIN,bar): $(call DYLIB,foo)
- $(CC) bar.c -lfoo -o $(call RUN_BINFILE,bar) -L $(TMPDIR)
-endif
-
-$(call DYLIB,foo): foo.rs
- $(RUSTC) foo.rs