summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/issue-69368
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /src/test/run-make-fulldeps/issue-69368
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/issue-69368')
-rw-r--r--src/test/run-make-fulldeps/issue-69368/Makefile18
-rw-r--r--src/test/run-make-fulldeps/issue-69368/a.rs26
-rw-r--r--src/test/run-make-fulldeps/issue-69368/b.rs8
-rw-r--r--src/test/run-make-fulldeps/issue-69368/c.rs34
4 files changed, 0 insertions, 86 deletions
diff --git a/src/test/run-make-fulldeps/issue-69368/Makefile b/src/test/run-make-fulldeps/issue-69368/Makefile
deleted file mode 100644
index 41770475d..000000000
--- a/src/test/run-make-fulldeps/issue-69368/Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
-include ../tools.mk
-
-# Test that previously triggered a linker failure with root cause
-# similar to one found in the issue #69368.
-#
-# The crate that provides oom lang item is missing some other lang
-# items. Necessary to prevent the use of start-group / end-group.
-#
-# The weak lang items are defined in a separate compilation units,
-# so that linker could omit them if not used.
-#
-# The crates that need those weak lang items are dependencies of
-# crates that provide them.
-
-all:
- $(RUSTC) a.rs
- $(RUSTC) b.rs
- $(RUSTC) c.rs
diff --git a/src/test/run-make-fulldeps/issue-69368/a.rs b/src/test/run-make-fulldeps/issue-69368/a.rs
deleted file mode 100644
index a54f42955..000000000
--- a/src/test/run-make-fulldeps/issue-69368/a.rs
+++ /dev/null
@@ -1,26 +0,0 @@
-#![crate_type = "rlib"]
-#![feature(lang_items)]
-#![feature(panic_unwind)]
-#![no_std]
-
-extern crate panic_unwind;
-
-#[panic_handler]
-pub fn panic_handler(_: &core::panic::PanicInfo) -> ! {
- loop {}
-}
-
-#[no_mangle]
-extern "C" fn __rust_drop_panic() -> ! {
- loop {}
-}
-
-#[no_mangle]
-extern "C" fn __rust_foreign_exception() -> ! {
- loop {}
-}
-
-#[lang = "eh_personality"]
-fn eh_personality() {
- loop {}
-}
diff --git a/src/test/run-make-fulldeps/issue-69368/b.rs b/src/test/run-make-fulldeps/issue-69368/b.rs
deleted file mode 100644
index 4d6af0266..000000000
--- a/src/test/run-make-fulldeps/issue-69368/b.rs
+++ /dev/null
@@ -1,8 +0,0 @@
-#![crate_type = "rlib"]
-#![feature(alloc_error_handler)]
-#![no_std]
-
-#[alloc_error_handler]
-pub fn error_handler(_: core::alloc::Layout) -> ! {
- panic!();
-}
diff --git a/src/test/run-make-fulldeps/issue-69368/c.rs b/src/test/run-make-fulldeps/issue-69368/c.rs
deleted file mode 100644
index 729c4249a..000000000
--- a/src/test/run-make-fulldeps/issue-69368/c.rs
+++ /dev/null
@@ -1,34 +0,0 @@
-#![crate_type = "bin"]
-#![feature(start)]
-#![no_std]
-
-extern crate alloc;
-extern crate a;
-extern crate b;
-
-use alloc::vec::Vec;
-use core::alloc::*;
-
-struct Allocator;
-
-unsafe impl GlobalAlloc for Allocator {
- unsafe fn alloc(&self, _: Layout) -> *mut u8 {
- loop {}
- }
-
- unsafe fn dealloc(&self, _: *mut u8, _: Layout) {
- loop {}
- }
-}
-
-#[global_allocator]
-static ALLOCATOR: Allocator = Allocator;
-
-#[start]
-fn main(argc: isize, _argv: *const *const u8) -> isize {
- let mut v = Vec::new();
- for i in 0..argc {
- v.push(i);
- }
- v.iter().sum()
-}