summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/target-cpu-native/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/target-cpu-native/Makefile
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/target-cpu-native/Makefile')
-rw-r--r--src/test/run-make-fulldeps/target-cpu-native/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/target-cpu-native/Makefile b/src/test/run-make-fulldeps/target-cpu-native/Makefile
new file mode 100644
index 000000000..d152e9f76
--- /dev/null
+++ b/src/test/run-make-fulldeps/target-cpu-native/Makefile
@@ -0,0 +1,20 @@
+-include ../tools.mk
+
+# only-linux
+# only-x86_64
+#
+# I *really* don't want to deal with a cross-platform way to compare file sizes,
+# tests in `make` sort of are awful
+
+all: $(TMPDIR)/out.log
+ # Make sure no warnings about "unknown CPU `native`" were emitted
+ if [ "$$(wc -c $(TMPDIR)/out.log | cut -d' ' -f 1)" = "0" ]; then \
+ echo no warnings generated; \
+ else \
+ exit 1; \
+ fi
+
+
+$(TMPDIR)/out.log:
+ $(RUSTC) foo.rs -C target-cpu=native 2>&1 | tee $(TMPDIR)/out.log
+ $(call RUN,foo)