summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/target-cpu-native
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /src/test/run-make-fulldeps/target-cpu-native
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/target-cpu-native')
-rw-r--r--src/test/run-make-fulldeps/target-cpu-native/Makefile20
-rw-r--r--src/test/run-make-fulldeps/target-cpu-native/foo.rs2
2 files changed, 0 insertions, 22 deletions
diff --git a/src/test/run-make-fulldeps/target-cpu-native/Makefile b/src/test/run-make-fulldeps/target-cpu-native/Makefile
deleted file mode 100644
index eb3ca1e13..000000000
--- a/src/test/run-make-fulldeps/target-cpu-native/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-include ../tools.mk
-
-# only-linux
-# only-x86_64
-#
-# I *really* don't want to deal with a cross-platform way to compare file sizes,
-# tests in `make` sort of are awful
-
-all: $(TMPDIR)/out.log
- # Make sure no warnings about "unknown CPU `native`" were emitted
- if [ "$$(wc -c $(TMPDIR)/out.log | cut -d' ' -f 1)" = "0" ]; then \
- echo no warnings generated; \
- else \
- exit 1; \
- fi
-
-
-$(TMPDIR)/out.log:
- $(RUSTC) foo.rs -C target-cpu=native 2>&1 | tee $(TMPDIR)/out.log
- $(call RUN,foo)
diff --git a/src/test/run-make-fulldeps/target-cpu-native/foo.rs b/src/test/run-make-fulldeps/target-cpu-native/foo.rs
deleted file mode 100644
index f79c691f0..000000000
--- a/src/test/run-make-fulldeps/target-cpu-native/foo.rs
+++ /dev/null
@@ -1,2 +0,0 @@
-fn main() {
-}