summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/rustdoc-verify-output-files/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
commit4547b622d8d29df964fa2914213088b148c498fc (patch)
tree9fc6b25f3c3add6b745be9a2400a6e96140046e9 /src/test/run-make/rustdoc-verify-output-files/Makefile
parentReleasing progress-linux version 1.66.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-4547b622d8d29df964fa2914213088b148c498fc.tar.xz
rustc-4547b622d8d29df964fa2914213088b148c498fc.zip
Merging upstream version 1.67.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make/rustdoc-verify-output-files/Makefile')
-rw-r--r--src/test/run-make/rustdoc-verify-output-files/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/test/run-make/rustdoc-verify-output-files/Makefile b/src/test/run-make/rustdoc-verify-output-files/Makefile
new file mode 100644
index 000000000..bfabbbc65
--- /dev/null
+++ b/src/test/run-make/rustdoc-verify-output-files/Makefile
@@ -0,0 +1,36 @@
+include ../../run-make-fulldeps/tools.mk
+
+OUTPUT_DIR := "$(TMPDIR)/rustdoc"
+TMP_OUTPUT_DIR := "$(TMPDIR)/tmp-rustdoc"
+
+all:
+ # Generate html docs
+ $(RUSTDOC) src/lib.rs --crate-name foobar --crate-type lib --out-dir $(OUTPUT_DIR)
+
+ # Copy first output for to check if it's exactly same after second compilation
+ cp -R $(OUTPUT_DIR) $(TMP_OUTPUT_DIR)
+
+ # Generate html docs once again on same output
+ $(RUSTDOC) src/lib.rs --crate-name foobar --crate-type lib --out-dir $(OUTPUT_DIR)
+
+ # Check if everything exactly same
+ $(DIFF) -r -q $(OUTPUT_DIR) $(TMP_OUTPUT_DIR)
+
+ # Generate json doc on the same output
+ $(RUSTDOC) src/lib.rs --crate-name foobar --crate-type lib --out-dir $(OUTPUT_DIR) -Z unstable-options --output-format json
+
+ # Check if expected json file is generated
+ [ -e $(OUTPUT_DIR)/foobar.json ]
+
+ # TODO
+ # We should re-generate json doc once again and compare the diff with previously
+ # generated one. Because layout of json docs changes in each compilation, we can't
+ # do that currently.
+ #
+ # See https://github.com/rust-lang/rust/issues/103785#issuecomment-1307425590 for details.
+
+ # remove generated json doc
+ rm $(OUTPUT_DIR)/foobar.json
+
+ # Check if json doc compilation broke any of the html files generated previously
+ $(DIFF) -r -q $(OUTPUT_DIR) $(TMP_OUTPUT_DIR)