summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/rustdoc-verify-output-files
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /src/test/run-make/rustdoc-verify-output-files
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make/rustdoc-verify-output-files')
-rw-r--r--src/test/run-make/rustdoc-verify-output-files/Makefile36
-rw-r--r--src/test/run-make/rustdoc-verify-output-files/src/lib.rs1
2 files changed, 0 insertions, 37 deletions
diff --git a/src/test/run-make/rustdoc-verify-output-files/Makefile b/src/test/run-make/rustdoc-verify-output-files/Makefile
deleted file mode 100644
index bfabbbc65..000000000
--- a/src/test/run-make/rustdoc-verify-output-files/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-include ../../run-make-fulldeps/tools.mk
-
-OUTPUT_DIR := "$(TMPDIR)/rustdoc"
-TMP_OUTPUT_DIR := "$(TMPDIR)/tmp-rustdoc"
-
-all:
- # Generate html docs
- $(RUSTDOC) src/lib.rs --crate-name foobar --crate-type lib --out-dir $(OUTPUT_DIR)
-
- # Copy first output for to check if it's exactly same after second compilation
- cp -R $(OUTPUT_DIR) $(TMP_OUTPUT_DIR)
-
- # Generate html docs once again on same output
- $(RUSTDOC) src/lib.rs --crate-name foobar --crate-type lib --out-dir $(OUTPUT_DIR)
-
- # Check if everything exactly same
- $(DIFF) -r -q $(OUTPUT_DIR) $(TMP_OUTPUT_DIR)
-
- # Generate json doc on the same output
- $(RUSTDOC) src/lib.rs --crate-name foobar --crate-type lib --out-dir $(OUTPUT_DIR) -Z unstable-options --output-format json
-
- # Check if expected json file is generated
- [ -e $(OUTPUT_DIR)/foobar.json ]
-
- # TODO
- # We should re-generate json doc once again and compare the diff with previously
- # generated one. Because layout of json docs changes in each compilation, we can't
- # do that currently.
- #
- # See https://github.com/rust-lang/rust/issues/103785#issuecomment-1307425590 for details.
-
- # remove generated json doc
- rm $(OUTPUT_DIR)/foobar.json
-
- # Check if json doc compilation broke any of the html files generated previously
- $(DIFF) -r -q $(OUTPUT_DIR) $(TMP_OUTPUT_DIR)
diff --git a/src/test/run-make/rustdoc-verify-output-files/src/lib.rs b/src/test/run-make/rustdoc-verify-output-files/src/lib.rs
deleted file mode 100644
index 5df757613..000000000
--- a/src/test/run-make/rustdoc-verify-output-files/src/lib.rs
+++ /dev/null
@@ -1 +0,0 @@
-// nothing to see here