summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/static-pie/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /src/test/run-make/static-pie/Makefile
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make/static-pie/Makefile')
-rw-r--r--src/test/run-make/static-pie/Makefile18
1 files changed, 0 insertions, 18 deletions
diff --git a/src/test/run-make/static-pie/Makefile b/src/test/run-make/static-pie/Makefile
deleted file mode 100644
index e71770636..000000000
--- a/src/test/run-make/static-pie/Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
-include ../../run-make-fulldeps/tools.mk
-
-# only-x86_64
-# only-linux
-# ignore-gnux32
-
-# How to manually run this
-# $ ./x.py test --target x86_64-unknown-linux-[musl,gnu] src/test/run-make/static-pie
-
-all: test-clang test-gcc
-
-test-%:
- if ./check_$*_version.sh; then\
- ${RUSTC} -Clinker=$* -Clinker-flavor=gcc --target ${TARGET} -C target-feature=+crt-static test-aslr.rs; \
- ! readelf -l $(call RUN_BINFILE,test-aslr) | $(CGREP) INTERP; \
- readelf -l $(call RUN_BINFILE,test-aslr) | $(CGREP) DYNAMIC; \
- $(call RUN,test-aslr) --test-aslr; \
- fi