summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/track-pgo-dep-info
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /src/test/run-make/track-pgo-dep-info
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make/track-pgo-dep-info')
-rw-r--r--src/test/run-make/track-pgo-dep-info/Makefile26
-rw-r--r--src/test/run-make/track-pgo-dep-info/main.rs1
2 files changed, 0 insertions, 27 deletions
diff --git a/src/test/run-make/track-pgo-dep-info/Makefile b/src/test/run-make/track-pgo-dep-info/Makefile
deleted file mode 100644
index 60b59c04a..000000000
--- a/src/test/run-make/track-pgo-dep-info/Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
-# needs-profiler-support
-# ignore-windows-gnu
-
--include ../../run-make-fulldeps/tools.mk
-
-# FIXME(eddyb) provide `HOST_RUSTC` and `TARGET_RUSTC`
-# instead of hardcoding them everywhere they're needed.
-ifeq ($(IS_MUSL_HOST),1)
-ADDITIONAL_ARGS := $(RUSTFLAGS)
-endif
-
-all:
- # Generate PGO profiles
- $(BARE_RUSTC) $(ADDITIONAL_ARGS) -Cprofile-generate=$(TMPDIR)/profiles --out-dir $(TMPDIR) main.rs
- $(TMPDIR)/main
-
- # Merge profiles
- "$(LLVM_BIN_DIR)/llvm-profdata" merge \
- -o "$(TMPDIR)/merged.profdata" \
- "$(TMPDIR)/profiles" || exit 1
-
- # Use the profile
- $(RUSTC) -Cprofile-use=$(TMPDIR)/merged.profdata --emit dep-info main.rs
-
- # Check that profile file is in depinfo
- $(CGREP) "merged.profdata" < $(TMPDIR)/main.d
diff --git a/src/test/run-make/track-pgo-dep-info/main.rs b/src/test/run-make/track-pgo-dep-info/main.rs
deleted file mode 100644
index f328e4d9d..000000000
--- a/src/test/run-make/track-pgo-dep-info/main.rs
+++ /dev/null
@@ -1 +0,0 @@
-fn main() {}