summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/wasm-stringify-ints-small
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /src/test/run-make/wasm-stringify-ints-small
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make/wasm-stringify-ints-small')
-rw-r--r--src/test/run-make/wasm-stringify-ints-small/Makefile10
-rw-r--r--src/test/run-make/wasm-stringify-ints-small/foo.rs33
2 files changed, 0 insertions, 43 deletions
diff --git a/src/test/run-make/wasm-stringify-ints-small/Makefile b/src/test/run-make/wasm-stringify-ints-small/Makefile
deleted file mode 100644
index 2fa2c954d..000000000
--- a/src/test/run-make/wasm-stringify-ints-small/Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
-include ../../run-make-fulldeps/tools.mk
-
-ifeq ($(TARGET),wasm32-unknown-unknown)
-all:
- $(RUSTC) foo.rs -C lto -O --target wasm32-unknown-unknown
- wc -c < $(TMPDIR)/foo.wasm
- [ "`wc -c < $(TMPDIR)/foo.wasm`" -lt "25000" ]
-else
-all:
-endif
diff --git a/src/test/run-make/wasm-stringify-ints-small/foo.rs b/src/test/run-make/wasm-stringify-ints-small/foo.rs
deleted file mode 100644
index 7a947f013..000000000
--- a/src/test/run-make/wasm-stringify-ints-small/foo.rs
+++ /dev/null
@@ -1,33 +0,0 @@
-#![crate_type = "cdylib"]
-
-extern "C" {
- fn observe(ptr: *const u8, len: usize);
-}
-
-macro_rules! s {
- ( $( $f:ident -> $t:ty );* $(;)* ) => {
- $(
- extern "C" {
- fn $f() -> $t;
- }
- let s = $f().to_string();
- observe(s.as_ptr(), s.len());
- )*
- };
-}
-
-#[no_mangle]
-pub unsafe extern "C" fn foo() {
- s! {
- get_u8 -> u8;
- get_i8 -> i8;
- get_u16 -> u16;
- get_i16 -> i16;
- get_u32 -> u32;
- get_i32 -> i32;
- get_u64 -> u64;
- get_i64 -> i64;
- get_usize -> usize;
- get_isize -> isize;
- }
-}