summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /src/test/run-make/x86_64-fortanix-unknown-sgx-lvi
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make/x86_64-fortanix-unknown-sgx-lvi')
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/Makefile23
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_asm.checks8
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_c.checks6
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_c_asm.checks15
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_cxx.checks6
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_cxx_asm.checks16
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_asm.checks7
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_c.checks6
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_c_asm.checks16
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_c_global_asm.checks2
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_cxx.checks6
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_cxx_asm.checks16
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_cxx_global_asm.checks2
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/Cargo.toml12
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/build.rs30
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/foo.c18
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/foo_asm.s7
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/foo_cxx.cpp21
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/CMakeLists.txt33
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/src/foo.c26
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/src/foo_asm.s7
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/src/foo_cxx.cpp29
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/src/main.rs49
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/jumpto.checks8
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/print.checks7
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/rust_plus_one_global_asm.checks2
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/script.sh58
-rw-r--r--src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/unw_getcontext.checks6
28 files changed, 0 insertions, 442 deletions
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/Makefile b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/Makefile
deleted file mode 100644
index 84dcd2393..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-include ../../run-make-fulldeps/tools.mk
-
-#only-x86_64-fortanix-unknown-sgx
-
-# For cargo setting
-export RUSTC := $(RUSTC_ORIGINAL)
-export LD_LIBRARY_PATH := $(HOST_RPATH_DIR)
-# We need to be outside of 'src' dir in order to run cargo
-export WORK_DIR := $(TMPDIR)
-export TEST_DIR := $(shell pwd)
-
-## clean up unused env variables which might cause harm.
-unexport RUSTC_LINKER
-unexport RUSTC_BOOTSTRAP
-unexport RUST_BUILD_STAGE
-unexport RUST_TEST_THREADS
-unexport RUST_TEST_TMPDIR
-unexport AR
-unexport CC
-unexport CXX
-
-all:
- bash script.sh
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_asm.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_asm.checks
deleted file mode 100644
index e839c200b..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_asm.checks
+++ /dev/null
@@ -1,8 +0,0 @@
-CHECK: cc_plus_one_asm
-CHECK-NEXT: movl
-CHECK-NEXT: lfence
-CHECK-NEXT: inc
-CHECK-NEXT: notq (%rsp)
-CHECK-NEXT: notq (%rsp)
-CHECK-NEXT: lfence
-CHECK-NEXT: retq
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_c.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_c.checks
deleted file mode 100644
index b93b33afb..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_c.checks
+++ /dev/null
@@ -1,6 +0,0 @@
-CHECK: cc_plus_one_c
-CHECK: lfence
-CHECK: popq
-CHECK-NEXT: popq [[REGISTER:%[a-z]+]]
-CHECK-NEXT: lfence
-CHECK-NEXT: jmpq *[[REGISTER]]
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_c_asm.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_c_asm.checks
deleted file mode 100644
index d1fae3d49..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_c_asm.checks
+++ /dev/null
@@ -1,15 +0,0 @@
-CHECK: cc_plus_one_c_asm
-CHECK: lfence
-CHECK: lfence
-CHECK: lfence
-CHECK: lfence
-CHECK: lfence
-CHECK-NEXT: incl
-CHECK-NEXT: jmp
-CHECK-NEXT: shlq $0, (%rsp)
-CHECK-NEXT: lfence
-CHECK-NEXT: retq
-CHECK: popq
-CHECK-NEXT: popq [[REGISTER:%[a-z]+]]
-CHECK-NEXT: lfence
-CHECK-NEXT: jmpq *[[REGISTER]]
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_cxx.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_cxx.checks
deleted file mode 100644
index f96f152c0..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_cxx.checks
+++ /dev/null
@@ -1,6 +0,0 @@
-CHECK: cc_plus_one_cxx
-CHECK: lfence
-CHECK: popq
-CHECK-NEXT: popq [[REGISTER:%[a-z]+]]
-CHECK-NEXT: lfence
-CHECK-NEXT: jmpq *[[REGISTER]]
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_cxx_asm.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_cxx_asm.checks
deleted file mode 100644
index e704bf417..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cc_plus_one_cxx_asm.checks
+++ /dev/null
@@ -1,16 +0,0 @@
-CHECK: cc_plus_one_cxx_asm
-CHECK: lfence
-CHECK: lfence
-CHECK: lfence
-CHECK: movl
-CHECK: lfence
-CHECK: lfence
-CHECK-NEXT: incl
-CHECK-NEXT: jmp 0x{{[[:xdigit:]]+}} <cc_plus_one_cxx_asm+0x{{[[:xdigit:]]+}}>
-CHECK-NEXT: shlq $0, (%rsp)
-CHECK-NEXT: lfence
-CHECK-NEXT: retq
-CHECK: popq
-CHECK-NEXT: popq [[REGISTER:%[a-z]+]]
-CHECK-NEXT: lfence
-CHECK-NEXT: jmpq *[[REGISTER]]
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_asm.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_asm.checks
deleted file mode 100644
index 78b18ccbf..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_asm.checks
+++ /dev/null
@@ -1,7 +0,0 @@
-CHECK: cmake_plus_one_asm
-CHECK-NEXT: movl
-CHECK-NEXT: lfence
-CHECK-NEXT: incl
-CHECK-NEXT: shlq $0, (%rsp)
-CHECK-NEXT: lfence
-CHECK-NEXT: retq
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_c.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_c.checks
deleted file mode 100644
index f551356b2..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_c.checks
+++ /dev/null
@@ -1,6 +0,0 @@
-CHECK: cmake_plus_one_c
-CHECK: lfence
-CHECK: popq
-CHECK-NEXT: popq [[REGISTER:%[a-z]+]]
-CHECK-NEXT: lfence
-CHECK-NEXT: jmpq *[[REGISTER]]
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_c_asm.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_c_asm.checks
deleted file mode 100644
index 87c806f13..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_c_asm.checks
+++ /dev/null
@@ -1,16 +0,0 @@
-CHECK: cmake_plus_one_c_asm
-CHECK: lfence
-CHECK: lfence
-CHECK: lfence
-CHECK: lfence
-CHECK: movl
-CHECK: lfence
-CHECK-NEXT: incl
-CHECK-NEXT: jmp 0x{{[[:xdigit:]]+}} <cmake_plus_one_c_asm+0x{{[[:xdigit:]]+}}>
-CHECK-NEXT: shlq $0, (%rsp)
-CHECK-NEXT: lfence
-CHECK-NEXT: retq
-CHECK: popq
-CHECK-NEXT: popq [[REGISTER:%[a-z]+]]
-CHECK-NEXT: lfence
-CHECK-NEXT: jmpq *[[REGISTER]]
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_c_global_asm.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_c_global_asm.checks
deleted file mode 100644
index 4b66cc5bc..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_c_global_asm.checks
+++ /dev/null
@@ -1,2 +0,0 @@
-CHECK: cmake_plus_one_c_global_asm
-CHECK: lfence
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_cxx.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_cxx.checks
deleted file mode 100644
index 0f403e020..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_cxx.checks
+++ /dev/null
@@ -1,6 +0,0 @@
-CHECK: cmake_plus_one_cxx
-CHECK: lfence
-CHECK: popq
-CHECK-NEXT: popq [[REGISTER:%[a-z]+]]
-CHECK-NEXT: lfence
-CHECK-NEXT: jmpq *[[REGISTER]]
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_cxx_asm.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_cxx_asm.checks
deleted file mode 100644
index 9cac8711e..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_cxx_asm.checks
+++ /dev/null
@@ -1,16 +0,0 @@
-CHECK: cmake_plus_one_cxx_asm
-CHECK: lfence
-CHECK: lfence
-CHECK: lfence
-CHECK: lfence
-CHECK: movl
-CHECK: lfence
-CHECK-NEXT: incl
-CHECK-NEXT: jmp 0x{{[[:xdigit:]]+}} <cmake_plus_one_cxx_asm+0x{{[[:xdigit:]]+}}>
-CHECK-NEXT: shlq $0, (%rsp)
-CHECK-NEXT: lfence
-CHECK-NEXT: retq
-CHECK: popq
-CHECK-NEXT: popq [[REGISTER:%[a-z]+]]
-CHECK-NEXT: lfence
-CHECK-NEXT: jmpq *[[REGISTER]]
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_cxx_global_asm.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_cxx_global_asm.checks
deleted file mode 100644
index d4a3d4479..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/cmake_plus_one_cxx_global_asm.checks
+++ /dev/null
@@ -1,2 +0,0 @@
-CHECK: cmake_plus_one_cxx_global_asm
-CHECK: lfence
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/Cargo.toml b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/Cargo.toml
deleted file mode 100644
index 3a97c37e9..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/Cargo.toml
+++ /dev/null
@@ -1,12 +0,0 @@
-[package]
-name = "enclave"
-version = "0.1.0"
-edition = "2018"
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[dependencies]
-
-[build-dependencies]
-cc = "1.0"
-cmake = "0.1"
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/build.rs b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/build.rs
deleted file mode 100644
index 3a7aa1be8..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/build.rs
+++ /dev/null
@@ -1,30 +0,0 @@
-fn main() {
- cc::Build::new()
- .file("foo.c")
- .compile("foo_c");
-
- cc::Build::new()
- .file("foo_asm.s")
- .compile("foo_asm");
-
- cc::Build::new()
- .cpp(true)
- .cpp_set_stdlib(None)
- .file("foo_cxx.cpp")
- .compile("foo_cxx");
-
- // When the cmake crate detects the clang compiler, it passes the
- // "--target" argument to the linker which subsequently fails. The
- // `CMAKE_C_COMPILER_FORCED` option makes sure that `cmake` does not
- // tries to test the compiler. From version 3.6 the option
- // `CMAKE_TRY_COMPILE_TARGET_TYPE=STATIC_LIBRARY` can be used
- // https://cmake.org/cmake/help/v3.5/module/CMakeForceCompiler.html
- let dst = cmake::Config::new("libcmake_foo")
- .build_target("cmake_foo")
- .define("CMAKE_C_COMPILER_FORCED", "1")
- .define("CMAKE_CXX_COMPILER_FORCED", "1")
- .define("CMAKE_TRY_COMPILE_TARGET_TYPE=STATIC_LIBRARY", "1")
- .build();
- println!("cargo:rustc-link-search=native={}/build/", dst.display());
- println!("cargo:rustc-link-lib=static=cmake_foo");
-}
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/foo.c b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/foo.c
deleted file mode 100644
index dd76d4f30..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/foo.c
+++ /dev/null
@@ -1,18 +0,0 @@
-int cc_plus_one_c(int *arg) {
- return *arg + 1;
-}
-
-int cc_plus_one_c_asm(int *arg) {
- int value = 0;
-
- asm volatile ( " movl (%1), %0\n"
- " inc %0\n"
- " jmp 1f\n"
- " retq\n" // never executed, but a shortcut to determine how
- // the assembler deals with `ret` instructions
- "1:\n"
- : "=r"(value)
- : "r"(arg) );
-
- return value;
-}
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/foo_asm.s b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/foo_asm.s
deleted file mode 100644
index 6d56214e8..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/foo_asm.s
+++ /dev/null
@@ -1,7 +0,0 @@
- .text
- .global cc_plus_one_asm
- .type cc_plus_one_asm, @function
-cc_plus_one_asm:
- movl (%rdi), %eax
- inc %eax
- retq
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/foo_cxx.cpp b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/foo_cxx.cpp
deleted file mode 100644
index ac6f64ac4..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/foo_cxx.cpp
+++ /dev/null
@@ -1,21 +0,0 @@
-extern "C" int cc_plus_one_cxx(int *arg);
-extern "C" int cc_plus_one_cxx_asm(int *arg);
-
-int cc_plus_one_cxx(int *arg) {
- return *arg + 1;
-}
-
-int cc_plus_one_cxx_asm(int *arg) {
- int value = 0;
-
- asm volatile ( " movl (%1), %0\n"
- " inc %0\n"
- " jmp 1f\n"
- " retq\n" // never executed, but a shortcut to determine how
- // the assembler deals with `ret` instructions
- "1:\n"
- : "=r"(value)
- : "r"(arg) );
-
- return value;
-}
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/CMakeLists.txt b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/CMakeLists.txt
deleted file mode 100644
index 27cdf2ecf..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/CMakeLists.txt
+++ /dev/null
@@ -1,33 +0,0 @@
-enable_language(C CXX ASM)
-
-set(C_SOURCES
- src/foo.c
- )
-
-set_source_files_properties(${C_SOURCES}
- PROPERTIES
- LANGUAGE C)
-
-set(CXX_SOURCES
- src/foo_cxx.cpp
- )
-
-set_source_files_properties(${CXX_SOURCES}
- PROPERTIES
- LANGUAGE CXX)
-
-set(ASM_SOURCES
- src/foo_asm.s
- )
-
-set_source_files_properties(${ASM_SOURCES}
- PROPERTIES
- LANGUAGE ASM)
-
-set(SOURCES
- ${C_SOURCES}
- ${CXX_SOURCES}
- ${ASM_SOURCES})
-
-add_library(cmake_foo STATIC
- ${SOURCES})
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/src/foo.c b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/src/foo.c
deleted file mode 100644
index c3b731a2d..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/src/foo.c
+++ /dev/null
@@ -1,26 +0,0 @@
-int cmake_plus_one_c(int *arg) {
- return *arg + 1;
-}
-
-int cmake_plus_one_c_asm(int *arg) {
- int value = 0;
-
- asm volatile ( " movl (%1), %0\n"
- " inc %0\n"
- " jmp 1f\n"
- " retq\n" // never executed, but a shortcut to determine how
- // the assembler deals with `ret` instructions
- "1:\n"
- : "=r"(value)
- : "r"(arg) );
-
- return value;
-}
-
-asm(".text\n"
-" .global cmake_plus_one_c_global_asm\n"
-" .type cmake_plus_one_c_global_asm, @function\n"
-"cmake_plus_one_c_global_asm:\n"
-" movl (%rdi), %eax\n"
-" inc %eax\n"
-" retq\n" );
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/src/foo_asm.s b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/src/foo_asm.s
deleted file mode 100644
index 64b6b430e..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/src/foo_asm.s
+++ /dev/null
@@ -1,7 +0,0 @@
- .text
- .global cmake_plus_one_asm
- .type cmake_plus_one_asm, @function
-cmake_plus_one_asm:
- movl (%rdi), %eax
- inc %eax
- retq
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/src/foo_cxx.cpp b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/src/foo_cxx.cpp
deleted file mode 100644
index 824e2afeb..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/src/foo_cxx.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
-extern "C" int cmake_plus_one_cxx(int *arg);
-extern "C" int cmake_plus_one_cxx_asm(int *arg);
-
-int cmake_plus_one_cxx(int *arg) {
- return *arg + 1;
-}
-
-int cmake_plus_one_cxx_asm(int *arg) {
- int value = 0;
-
- asm volatile ( " movl (%1), %0\n"
- " inc %0\n"
- " jmp 1f\n"
- " retq\n" // never executed, but a shortcut to determine how
- // the assembler deals with `ret` instructions
- "1:\n"
- : "=r"(value)
- : "r"(arg) );
-
- return value;
-}
-
-asm(".text\n"
-" .global cmake_plus_one_cxx_global_asm\n"
-" .type cmake_plus_one_cxx_global_asm, @function\n"
-"cmake_plus_one_cxx_global_asm:\n"
-" movl (%rdi), %eax\n"
-" inc %eax\n"
-" retq\n" );
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/src/main.rs b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/src/main.rs
deleted file mode 100644
index cde38aacf..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/src/main.rs
+++ /dev/null
@@ -1,49 +0,0 @@
-std::arch::global_asm!(
- r#"
- .text
- .global rust_plus_one_global_asm
- .type rust_plus_one_global_asm, @function
-rust_plus_one_global_asm:
- movl (%rdi), %eax
- inc %eax
- retq
-"#,
- options(att_syntax)
-);
-
-extern "C" {
- fn cc_plus_one_c(arg: &u32) -> u32;
- fn cc_plus_one_c_asm(arg: &u32) -> u32;
- fn cc_plus_one_cxx(arg: &u32) -> u32;
- fn cc_plus_one_cxx_asm(arg: &u32) -> u32;
- fn cc_plus_one_asm(arg: &u32) -> u32;
- fn cmake_plus_one_c(arg: &u32) -> u32;
- fn cmake_plus_one_c_asm(arg: &u32) -> u32;
- fn cmake_plus_one_cxx(arg: &u32) -> u32;
- fn cmake_plus_one_cxx_asm(arg: &u32) -> u32;
- fn cmake_plus_one_c_global_asm(arg: &u32) -> u32;
- fn cmake_plus_one_cxx_global_asm(arg: &u32) -> u32;
- fn cmake_plus_one_asm(arg: &u32) -> u32;
- fn rust_plus_one_global_asm(arg: &u32) -> u32;
-}
-
-fn main() {
- let value: u32 = 41;
- let question = "Answer to the Ultimate Question of Life, the Universe, and Everything:";
-
- unsafe {
- println!("{}: {}!", question, rust_plus_one_global_asm(&value));
- println!("{}: {}!", question, cc_plus_one_c(&value));
- println!("{}: {}!", question, cc_plus_one_c_asm(&value));
- println!("{}: {}!", question, cc_plus_one_cxx(&value));
- println!("{}: {}!", question, cc_plus_one_cxx_asm(&value));
- println!("{}: {}!", question, cc_plus_one_asm(&value));
- println!("{}: {}!", question, cmake_plus_one_c(&value));
- println!("{}: {}!", question, cmake_plus_one_c_asm(&value));
- println!("{}: {}!", question, cmake_plus_one_cxx(&value));
- println!("{}: {}!", question, cmake_plus_one_cxx_asm(&value));
- println!("{}: {}!", question, cmake_plus_one_c_global_asm(&value));
- println!("{}: {}!", question, cmake_plus_one_cxx_global_asm(&value));
- println!("{}: {}!", question, cmake_plus_one_asm(&value));
- }
-}
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/jumpto.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/jumpto.checks
deleted file mode 100644
index 15211e3ad..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/jumpto.checks
+++ /dev/null
@@ -1,8 +0,0 @@
-CHECK: libunwind::Registers_x86_64::jumpto
-CHECK: lfence
-CHECK: lfence
-CHECK: lfence
-CHECK: lfence
-CHECK: shlq $0, (%rsp)
-CHECK-NEXT: lfence
-CHECK-NEXT: retq
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/print.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/print.checks
deleted file mode 100644
index 0fe88141b..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/print.checks
+++ /dev/null
@@ -1,7 +0,0 @@
-CHECK: print
-CHECK: lfence
-CHECK: lfence
-CHECK: lfence
-CHECK: popq
-CHECK: callq 0x{{[[:xdigit:]]*}} <_Unwind_Resume>
-CHECK-NEXT: ud2
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/rust_plus_one_global_asm.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/rust_plus_one_global_asm.checks
deleted file mode 100644
index fe6777537..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/rust_plus_one_global_asm.checks
+++ /dev/null
@@ -1,2 +0,0 @@
-CHECK: rust_plus_one_global_asm
-CHECK: lfence
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/script.sh b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/script.sh
deleted file mode 100644
index 944343df6..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/script.sh
+++ /dev/null
@@ -1,58 +0,0 @@
-#!/bin/sh
-set -exuo pipefail
-
-function build {
- CRATE=enclave
-
- mkdir -p $WORK_DIR
- pushd $WORK_DIR
- rm -rf $CRATE
- cp -a $TEST_DIR/enclave .
- pushd $CRATE
- echo ${WORK_DIR}
- # HACK(eddyb) sets `RUSTC_BOOTSTRAP=1` so Cargo can accept nightly features.
- # These come from the top-level Rust workspace, that this crate is not a
- # member of, but Cargo tries to load the workspace `Cargo.toml` anyway.
- env RUSTC_BOOTSTRAP=1
- cargo -v run --target $TARGET
- popd
- popd
-}
-
-function check {
- local func=$1
- local checks="${TEST_DIR}/$2"
- local asm=$(mktemp)
- local objdump="${BUILD_DIR}/x86_64-unknown-linux-gnu/llvm/build/bin/llvm-objdump"
- local filecheck="${BUILD_DIR}/x86_64-unknown-linux-gnu/llvm/build/bin/FileCheck"
-
- ${objdump} --disassemble-symbols=${func} --demangle \
- ${WORK_DIR}/enclave/target/x86_64-fortanix-unknown-sgx/debug/enclave > ${asm}
- ${filecheck} --input-file ${asm} ${checks}
-}
-
-build
-
-check unw_getcontext unw_getcontext.checks
-check "libunwind::Registers_x86_64::jumpto()" jumpto.checks
-check "std::io::stdio::_print::h87f0c238421c45bc" print.checks
-check rust_plus_one_global_asm rust_plus_one_global_asm.checks \
- || echo "warning: module level assembly currently not hardened"
-
-check cc_plus_one_c cc_plus_one_c.checks
-check cc_plus_one_c_asm cc_plus_one_c_asm.checks
-check cc_plus_one_cxx cc_plus_one_cxx.checks
-check cc_plus_one_cxx_asm cc_plus_one_cxx_asm.checks
-check cc_plus_one_asm cc_plus_one_asm.checks \
- || echo "warning: the cc crate forwards assembly files to the CC compiler." \
- "Clang uses its own integrated assembler, which does not include the LVI passes."
-
-check cmake_plus_one_c cmake_plus_one_c.checks
-check cmake_plus_one_c_asm cmake_plus_one_c_asm.checks
-check cmake_plus_one_c_global_asm cmake_plus_one_c_global_asm.checks \
- || echo "warning: module level assembly currently not hardened"
-check cmake_plus_one_cxx cmake_plus_one_cxx.checks
-check cmake_plus_one_cxx_asm cmake_plus_one_cxx_asm.checks
-check cmake_plus_one_cxx_global_asm cmake_plus_one_cxx_global_asm.checks \
- || echo "warning: module level assembly currently not hardened"
-check cmake_plus_one_asm cmake_plus_one_asm.checks
diff --git a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/unw_getcontext.checks b/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/unw_getcontext.checks
deleted file mode 100644
index 4b7615b11..000000000
--- a/src/test/run-make/x86_64-fortanix-unknown-sgx-lvi/unw_getcontext.checks
+++ /dev/null
@@ -1,6 +0,0 @@
-CHECK: unw_getcontext
-CHECK: lfence
-CHECK: lfence
-CHECK: shlq $0, (%rsp)
-CHECK-NEXT: lfence
-CHECK-NEXT: retq