summaryrefslogtreecommitdiffstats
path: root/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:35 +0000
commitd1b2d29528b7794b41e66fc2136e395a02f8529b (patch)
treea4a17504b260206dec3cf55b2dca82929a348ac2 /src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit
parentReleasing progress-linux version 1.72.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-d1b2d29528b7794b41e66fc2136e395a02f8529b.tar.xz
rustc-d1b2d29528b7794b41e66fc2136e395a02f8529b.zip
Merging upstream version 1.73.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit')
-rw-r--r--src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/in/src/main.rs4
-rw-r--r--src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/mod.rs21
-rw-r--r--src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/out/Cargo.toml8
-rw-r--r--src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/out/src/main.rs4
-rw-r--r--src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/stderr.log1
-rw-r--r--src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/stdout.log0
6 files changed, 0 insertions, 38 deletions
diff --git a/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/in/src/main.rs b/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/in/src/main.rs
deleted file mode 100644
index 65fdcf8da..000000000
--- a/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/in/src/main.rs
+++ /dev/null
@@ -1,4 +0,0 @@
-fn main() {
- println!("Check that our file is not overwritten")
-}
-
diff --git a/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/mod.rs b/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/mod.rs
deleted file mode 100644
index 326bd218a..000000000
--- a/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/mod.rs
+++ /dev/null
@@ -1,21 +0,0 @@
-use cargo_test_support::compare::assert_ui;
-use cargo_test_support::prelude::*;
-use cargo_test_support::Project;
-
-use cargo_test_support::curr_dir;
-
-#[cargo_test]
-fn case() {
- let project = Project::from_template(curr_dir!().join("in"));
- let project_root = &project.root();
-
- snapbox::cmd::Command::cargo_ui()
- .arg_line("init --bin --vcs none")
- .current_dir(project_root)
- .assert()
- .success()
- .stdout_matches_path(curr_dir!().join("stdout.log"))
- .stderr_matches_path(curr_dir!().join("stderr.log"));
-
- assert_ui().subset_matches(curr_dir!().join("out"), project_root);
-}
diff --git a/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/out/Cargo.toml b/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/out/Cargo.toml
deleted file mode 100644
index dcdb8da2c..000000000
--- a/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/out/Cargo.toml
+++ /dev/null
@@ -1,8 +0,0 @@
-[package]
-name = "case"
-version = "0.1.0"
-edition = "2021"
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[dependencies]
diff --git a/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/out/src/main.rs b/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/out/src/main.rs
deleted file mode 100644
index 65fdcf8da..000000000
--- a/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/out/src/main.rs
+++ /dev/null
@@ -1,4 +0,0 @@
-fn main() {
- println!("Check that our file is not overwritten")
-}
-
diff --git a/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/stderr.log b/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/stderr.log
deleted file mode 100644
index 3847e4e4a..000000000
--- a/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/stderr.log
+++ /dev/null
@@ -1 +0,0 @@
- Created binary (application) package
diff --git a/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/stdout.log b/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/stdout.log
deleted file mode 100644
index e69de29bb..000000000
--- a/src/tools/cargo/tests/testsuite/init/bin_already_exists_explicit/stdout.log
+++ /dev/null