summaryrefslogtreecommitdiffstats
path: root/src/tools/cargo/tests/testsuite/profile_custom.rs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-19 09:26:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-19 09:26:03 +0000
commit9918693037dce8aa4bb6f08741b6812923486c18 (patch)
tree21d2b40bec7e6a7ea664acee056eb3d08e15a1cf /src/tools/cargo/tests/testsuite/profile_custom.rs
parentReleasing progress-linux version 1.75.0+dfsg1-5~progress7.99u1. (diff)
downloadrustc-9918693037dce8aa4bb6f08741b6812923486c18.tar.xz
rustc-9918693037dce8aa4bb6f08741b6812923486c18.zip
Merging upstream version 1.76.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/tools/cargo/tests/testsuite/profile_custom.rs')
-rw-r--r--src/tools/cargo/tests/testsuite/profile_custom.rs16
1 files changed, 14 insertions, 2 deletions
diff --git a/src/tools/cargo/tests/testsuite/profile_custom.rs b/src/tools/cargo/tests/testsuite/profile_custom.rs
index f7139e552..cf9828d37 100644
--- a/src/tools/cargo/tests/testsuite/profile_custom.rs
+++ b/src/tools/cargo/tests/testsuite/profile_custom.rs
@@ -86,6 +86,10 @@ fn invalid_profile_name() {
[ERROR] failed to parse manifest at [..]
Caused by:
+ TOML parse error at line 7, column 26
+ |
+ 7 | [profile.'.release-lto']
+ | ^^^^^^^^^^^^^^
invalid character `.` in profile name `.release-lto`
Allowed characters are letters, numbers, underscore, and hyphen.
",
@@ -626,6 +630,7 @@ See https://doc.rust-lang.org/cargo/reference/profiles.html for more on configur
),
);
+ let highlight = "^".repeat(name.len());
p.cargo("build")
.with_status(101)
.with_stderr(&format!(
@@ -633,11 +638,14 @@ See https://doc.rust-lang.org/cargo/reference/profiles.html for more on configur
error: failed to parse manifest at `[ROOT]/foo/Cargo.toml`
Caused by:
- profile name `{}` is reserved
+ TOML parse error at line 6, column 30
+ |
+ 6 | [profile.{name}]
+ | {highlight}
+ profile name `{name}` is reserved
Please choose a different name.
See https://doc.rust-lang.org/cargo/reference/profiles.html for more on configuring profiles.
",
- name
))
.run();
}
@@ -663,6 +671,10 @@ Caused by:
error: failed to parse manifest at `[ROOT]/foo/Cargo.toml`
Caused by:
+ TOML parse error at line 7, column 25
+ |
+ 7 | [profile.debug]
+ | ^^^^^
profile name `debug` is reserved
To configure the default development profile, use the name `dev` as in [profile.dev]
See https://doc.rust-lang.org/cargo/reference/profiles.html for more on configuring profiles.