summaryrefslogtreecommitdiffstats
path: root/src/tools/rust-analyzer/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /src/tools/rust-analyzer/Cargo.toml
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/tools/rust-analyzer/Cargo.toml')
-rw-r--r--src/tools/rust-analyzer/Cargo.toml18
1 files changed, 17 insertions, 1 deletions
diff --git a/src/tools/rust-analyzer/Cargo.toml b/src/tools/rust-analyzer/Cargo.toml
index 333f03ce2..3050cf764 100644
--- a/src/tools/rust-analyzer/Cargo.toml
+++ b/src/tools/rust-analyzer/Cargo.toml
@@ -1,6 +1,7 @@
[workspace]
members = ["xtask/", "lib/*", "crates/*"]
exclude = ["crates/proc-macro-test/imp"]
+resolver = "2"
[workspace.package]
rust-version = "1.66"
@@ -74,5 +75,20 @@ toolchain = { path = "./crates/toolchain", version = "0.0.0" }
tt = { path = "./crates/tt", version = "0.0.0" }
vfs-notify = { path = "./crates/vfs-notify", version = "0.0.0" }
vfs = { path = "./crates/vfs", version = "0.0.0" }
+line-index = { version = "0.1.0-pre.1", path = "./lib/line-index" }
+
# non-local crates
-smallvec = { version = "1.10.0", features = ["const_new", "union", "const_generics"] }
+smallvec = { version = "1.10.0", features = [
+ "const_new",
+ "union",
+ "const_generics",
+] }
+smol_str = "0.2.0"
+nohash-hasher = "0.2.0"
+text-size = "1.1.0"
+# the following crates are pinned to prevent us from pulling in syn 2 until all our dependencies have moved
+serde = { version = "=1.0.156", features = ["derive"] }
+serde_json = "1.0.94"
+triomphe = { version = "0.1.8", default-features = false, features = ["std"] }
+
+rustc_lexer = { version = "0.1.0", package = "ra-ap-rustc_lexer" }