summaryrefslogtreecommitdiffstats
path: root/src/tools/rust-analyzer/lib/lsp-server
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /src/tools/rust-analyzer/lib/lsp-server
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/tools/rust-analyzer/lib/lsp-server')
-rw-r--r--src/tools/rust-analyzer/lib/lsp-server/Cargo.toml4
-rw-r--r--src/tools/rust-analyzer/lib/lsp-server/src/error.rs2
-rw-r--r--src/tools/rust-analyzer/lib/lsp-server/src/lib.rs70
3 files changed, 73 insertions, 3 deletions
diff --git a/src/tools/rust-analyzer/lib/lsp-server/Cargo.toml b/src/tools/rust-analyzer/lib/lsp-server/Cargo.toml
index 6e32e3960..e78a9d2eb 100644
--- a/src/tools/rust-analyzer/lib/lsp-server/Cargo.toml
+++ b/src/tools/rust-analyzer/lib/lsp-server/Cargo.toml
@@ -8,8 +8,8 @@ edition = "2021"
[dependencies]
log = "0.4.17"
-serde_json = "1.0.86"
-serde = { version = "1.0.144", features = ["derive"] }
+serde_json.workspace = true
+serde.workspace = true
crossbeam-channel = "0.5.6"
[dev-dependencies]
diff --git a/src/tools/rust-analyzer/lib/lsp-server/src/error.rs b/src/tools/rust-analyzer/lib/lsp-server/src/error.rs
index 4c934d9ec..755b3fd95 100644
--- a/src/tools/rust-analyzer/lib/lsp-server/src/error.rs
+++ b/src/tools/rust-analyzer/lib/lsp-server/src/error.rs
@@ -2,7 +2,7 @@ use std::fmt;
use crate::{Notification, Request};
-#[derive(Debug, Clone)]
+#[derive(Debug, Clone, PartialEq)]
pub struct ProtocolError(pub(crate) String);
impl std::error::Error for ProtocolError {}
diff --git a/src/tools/rust-analyzer/lib/lsp-server/src/lib.rs b/src/tools/rust-analyzer/lib/lsp-server/src/lib.rs
index beccde40a..affab60a2 100644
--- a/src/tools/rust-analyzer/lib/lsp-server/src/lib.rs
+++ b/src/tools/rust-analyzer/lib/lsp-server/src/lib.rs
@@ -126,6 +126,9 @@ impl Connection {
self.sender.send(resp.into()).unwrap();
continue;
}
+ Ok(Message::Notification(n)) if !n.is_exit() => {
+ continue;
+ }
Ok(msg) => Err(ProtocolError(format!("expected initialize request, got {msg:?}"))),
Err(e) => {
Err(ProtocolError(format!("expected initialize request, got error: {e}")))
@@ -212,3 +215,70 @@ impl Connection {
Ok(true)
}
}
+
+#[cfg(test)]
+mod tests {
+ use crossbeam_channel::unbounded;
+ use lsp_types::notification::{Exit, Initialized, Notification};
+ use lsp_types::request::{Initialize, Request};
+ use lsp_types::{InitializeParams, InitializedParams};
+ use serde_json::to_value;
+
+ use crate::{Connection, Message, ProtocolError, RequestId};
+
+ struct TestCase {
+ test_messages: Vec<Message>,
+ expected_resp: Result<(RequestId, serde_json::Value), ProtocolError>,
+ }
+
+ fn initialize_start_test(test_case: TestCase) {
+ let (reader_sender, reader_receiver) = unbounded::<Message>();
+ let (writer_sender, writer_receiver) = unbounded::<Message>();
+ let conn = Connection { sender: writer_sender, receiver: reader_receiver };
+
+ for msg in test_case.test_messages {
+ assert!(reader_sender.send(msg).is_ok());
+ }
+
+ let resp = conn.initialize_start();
+ assert_eq!(test_case.expected_resp, resp);
+
+ assert!(writer_receiver.recv_timeout(std::time::Duration::from_secs(1)).is_err());
+ }
+
+ #[test]
+ fn not_exit_notification() {
+ let notification = crate::Notification {
+ method: Initialized::METHOD.to_string(),
+ params: to_value(InitializedParams {}).unwrap(),
+ };
+
+ let params_as_value = to_value(InitializeParams::default()).unwrap();
+ let req_id = RequestId::from(234);
+ let request = crate::Request {
+ id: req_id.clone(),
+ method: Initialize::METHOD.to_string(),
+ params: params_as_value.clone(),
+ };
+
+ initialize_start_test(TestCase {
+ test_messages: vec![notification.into(), request.into()],
+ expected_resp: Ok((req_id, params_as_value)),
+ });
+ }
+
+ #[test]
+ fn exit_notification() {
+ let notification =
+ crate::Notification { method: Exit::METHOD.to_string(), params: to_value(()).unwrap() };
+ let notification_msg = Message::from(notification);
+
+ initialize_start_test(TestCase {
+ test_messages: vec![notification_msg.clone()],
+ expected_resp: Err(ProtocolError(format!(
+ "expected initialize request, got {:?}",
+ notification_msg
+ ))),
+ });
+ }
+}