summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/allow-non-lint-warnings-cmdline
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/allow-non-lint-warnings-cmdline')
-rw-r--r--tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile11
-rw-r--r--tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/foo.rs5
2 files changed, 0 insertions, 16 deletions
diff --git a/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile b/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
deleted file mode 100644
index 60d9c7c37..000000000
--- a/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
-include ../tools.mk
-
-# Test that -A warnings makes the 'empty trait list for derive' warning go away
-OUT=$(shell $(RUSTC) foo.rs -A warnings 2>&1 | grep "warning" )
-
-all: foo
- test -z '$(OUT)'
-
-# This is just to make sure the above command actually succeeds
-foo:
- $(RUSTC) foo.rs -A warnings
diff --git a/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/foo.rs b/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/foo.rs
deleted file mode 100644
index 46e72da2d..000000000
--- a/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/foo.rs
+++ /dev/null
@@ -1,5 +0,0 @@
-#[derive()]
-#[derive(Copy, Clone)]
-pub struct Foo;
-
-pub fn main() { }